brcm63xx: F@ST2504n board support (image, base-files) fast2504n-3.10.26
authornorly <ny-git@enpas.org>
Mon, 20 May 2013 12:54:07 +0000 (13:54 +0100)
committerMax Staudt <openwrt.max@enpas.org>
Wed, 15 Jan 2014 19:00:27 +0000 (20:00 +0100)
target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/image/Makefile

index d7f6c3a46d202abab964f8509274cffc64e6807a..ab2f99f94aa4ca485e7b68d1c8a5fa9d48d80400 100755 (executable)
@@ -80,7 +80,8 @@ DVG3810BN)
 96328A-1441N1 |\
 963281TAN |\
 963281T_TEF |\
-96368MVNgr)
+96368MVNgr |\
+"F@ST2504n")
        ucidef_set_interface_lan "eth0.1"
        ucidef_add_switch "eth0" "1" "1"
        ucidef_add_switch_vlan "eth0" "1" "0 1 2 3 8t"
index 7c449ae6adc11d7ab1e8eac296d2d6d431d28688..1ed939d11d97ac402a8d38c4aba7da1f16c70057 100755 (executable)
@@ -121,6 +121,11 @@ brcm63xx_detect() {
                brcm63xx_has_reset_button="true"
                ifname=eth0
                ;;
+       "F@ST2504n")
+               status_led="fast2504n:green:ok"
+               brcm63xx_has_reset_button="true"
+               ifname=eth0
+               ;;
        *)
                ;;
        esac
index dc11c33705b31d719b85ebc54adc9494190dc964..a9bfe2415ea41882795713399f0999568ee83b38 100755 (executable)
@@ -218,6 +218,9 @@ define Image/Build
        # Neufbox6
        $(call Image/Build/CFE,$(1),NB6-SER-r0,6362,NEUFBOX6,OpenWRT-$(REVISION))
 
+       # Sagem F@ST2504n
+       $(call Image/Build/CFE,$(1),F@ST2504n,6362,F@ST2504n,OpenWRT-$(REVISION))
+
        # Comtrend 6373
        $(call Image/Build/CFE,$(1),CT6373-1,6358,CT6373)
        # Comtrend 536, 5621