lldpd: build without libreadline
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 29 Jan 2014 13:10:39 +0000 (13:10 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 29 Jan 2014 13:10:39 +0000 (13:10 +0000)
lldpcli uses libreadline for tab completion. libreadline take around 110kb.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39421 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/lldpd/Makefile

index 49940cdeea691fe28454d6c27cdbee5a5d4db273..31367833ec555d650832c6bae833784207963018 100644 (file)
@@ -59,6 +59,7 @@ endef
 CONFIGURE_ARGS += \
        --with-privsep-user=lldp \
        --with-privsep-group=lldp \
-       --with-privsep-chroot=/var/run/lldp
+       --with-privsep-chroot=/var/run/lldp \
+       --with-readline=no
 
 $(eval $(call BuildPackage,lldpd))