kernel/modules: snd-pcm-dmaengine only if CONFIG_SND_DMAENGINE_PCM is set
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Nov 2013 14:09:48 +0000 (14:09 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Nov 2013 14:09:48 +0000 (14:09 +0000)
Platforms without in-soc audio don't provide CONFIG_SND_DMAENGINE_PCM, thus
the module is not generated.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38913 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/sound.mk

index 4e1a656dd2707286677786ec2485bce05787e4b6..bed2e3c8021c05214250fa8bd1a4ffd077014abe 100644 (file)
@@ -42,10 +42,10 @@ endif
 
 ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.12.0)),1)
 SOUNDCORE_LOAD += \
-       snd-pcm-dmaengine
+       $(if $(CONFIG_SND_DMAENGINE_PCM),snd-pcm-dmaengine)
 
 SOUNDCORE_FILES += \
-       $(LINUX_DIR)/sound/core/snd-pcm-dmaengine.ko
+       $(if $(CONFIG_SND_DMAENGINE_PCM),$(LINUX_DIR)/sound/core/snd-pcm-dmaengine.ko)
 endif
 
 define KernelPackage/sound-core