build: set owner root for all files on ubifs creation
[openwrt.git] / include / image.mk
index 729929f9da1ca91bc5a997af813d8c680ee7e9f6..c7da0600c3376b82d0e8d6e985e23d22880e3dc0 100644 (file)
@@ -139,6 +139,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
                        $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_LZO),--force-compr=lzo) \
                        $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_ZLIB),--force-compr=zlib) \
                        --jrn-size=$(CONFIG_TARGET_UBIFS_JOURNAL_SIZE) \
+                       --squash-uids \
                        -o $(KDIR)/root.ubifs \
                        -d $(TARGET_DIR)
         endif