summaryrefslogtreecommitdiff
path: root/openwrt/package/sablevm
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/sablevm')
-rw-r--r--openwrt/package/sablevm/Makefile4
-rw-r--r--openwrt/package/sablevm/patches/001-heap_size.patch15
2 files changed, 17 insertions, 2 deletions
diff --git a/openwrt/package/sablevm/Makefile b/openwrt/package/sablevm/Makefile
index 7eec3f4924..d09b116843 100644
--- a/openwrt/package/sablevm/Makefile
+++ b/openwrt/package/sablevm/Makefile
@@ -3,9 +3,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=sablevm
-PKG_VERSION:=1.11.3
+PKG_VERSION:=1.13
PKG_RELEASE:=1
-PKG_MD5SUM:=aea6e808c5f2e3646a60971485220bff
+PKG_MD5SUM:=d5828200032bfe921dd43e450931e38c
PKG_SOURCE_URL:=http://sablevm.org/download/release/$(PKG_VERSION)/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/openwrt/package/sablevm/patches/001-heap_size.patch b/openwrt/package/sablevm/patches/001-heap_size.patch
new file mode 100644
index 0000000000..d28237296a
--- /dev/null
+++ b/openwrt/package/sablevm/patches/001-heap_size.patch
@@ -0,0 +1,15 @@
+diff -ruN sablevm-1.11.1-orig/src/libsablevm/system.h sablevm-1.11.1-1/src/libsablevm/system.h
+--- sablevm-1.11.1-orig/src/libsablevm/system.h 2005-03-18 01:25:09.000000000 +0100
++++ sablevm-1.11.1-1/src/libsablevm/system.h 2005-03-22 01:05:19.000000000 +0100
+@@ -279,9 +279,9 @@
+
+ #elif defined (_SABLEVM_COPY_GC) || (_SABLEVM_GENCOPY_GC)
+
+-#define SVM_HEAP_DEFAULT_MIN_SIZE 16777216
++#define SVM_HEAP_DEFAULT_MIN_SIZE 1048576
+ #define SVM_HEAP_DEFAULT_MAX_SIZE 0
+-#define SVM_HEAP_DEFAULT_ALLOCATION_INCREMENT 1048576
++#define SVM_HEAP_DEFAULT_ALLOCATION_INCREMENT 65536
+
+ #if defined (_SABLEVM_GENCOPY_GC)
+