summaryrefslogtreecommitdiff
path: root/openwrt/package/rrdtool
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/package/rrdtool')
-rw-r--r--openwrt/package/rrdtool/Config.in67
-rw-r--r--openwrt/package/rrdtool/Makefile111
-rw-r--r--openwrt/package/rrdtool/ipkg/librrd.control14
-rw-r--r--openwrt/package/rrdtool/ipkg/rrdcgi.control15
-rw-r--r--openwrt/package/rrdtool/ipkg/rrdtool.control14
5 files changed, 0 insertions, 221 deletions
diff --git a/openwrt/package/rrdtool/Config.in b/openwrt/package/rrdtool/Config.in
deleted file mode 100644
index 6993c4e0e3..0000000000
--- a/openwrt/package/rrdtool/Config.in
+++ /dev/null
@@ -1,67 +0,0 @@
-config BR2_COMPILE_RRDTOOL
- prompt "rrdtool........................... Round Robin Database (RRD) tools (v1.2.x)"
- bool
- default n
-
-config BR2_PACKAGE_LIBRRD
- prompt "librrd.......................... Round Robin Database (RRD) management library (v1.2.x)"
- tristate
- default n
- depends BR2_COMPILE_RRDTOOL
- select BR2_PACKAGE_LIBART
- select BR2_PACKAGE_LIBFREETYPE
- select BR2_PACKAGE_LIBPNG
- select BR2_PACKAGE_ZLIB
- help
- RRD is the Acronym for Round Robin Database. RRD is a system to store and
- display time-series data (i.e. network bandwidth, machine-room temperature,
- server load average). It stores the data in a very compact way that will
- not expand over time, and it presents useful graphs by processing the data
- to enforce a certain data density. It can be used either via simple wrapper
- scripts (from shell or Perl) or via frontends that poll network devices and
- put friendly user interface on it.
-
- http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/
-
- This package contains command line tools used to manage RRDs.
-
-config BR2_PACKAGE_RRDCGI
- prompt "rrdcgi.......................... Round Robin Database (RRD) CGI graphing tool (v1.2.x)"
- tristate
- default n
- depends BR2_COMPILE_RRDTOOL
- select BR2_PACKAGE_LIBRRD
- select BR2_PACKAGE_CGILIB
- help
- RRD is the Acronym for Round Robin Database. RRD is a system to store and
- display time-series data (i.e. network bandwidth, machine-room temperature,
- server load average). It stores the data in a very compact way that will
- not expand over time, and it presents useful graphs by processing the data
- to enforce a certain data density. It can be used either via simple wrapper
- scripts (from shell or Perl) or via frontends that poll network devices and
- put friendly user interface on it.
-
- http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/
-
- This package contains the rrdcgi tool used to create web pages containing
- RRD graphs based on templates.
-
-config BR2_PACKAGE_RRDTOOL
- prompt "rrdtool......................... Round Robin Database (RRD) management tools (v1.2.x)"
- tristate
- default n
- depends BR2_COMPILE_RRDTOOL
- select BR2_PACKAGE_LIBRRD
- help
- RRD is the Acronym for Round Robin Database. RRD is a system to store and
- display time-series data (i.e. network bandwidth, machine-room temperature,
- server load average). It stores the data in a very compact way that will
- not expand over time, and it presents useful graphs by processing the data
- to enforce a certain data density. It can be used either via simple wrapper
- scripts (from shell or Perl) or via frontends that poll network devices and
- put friendly user interface on it.
-
- http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/
-
- This package contains command line tools used to manage RRDs.
-
diff --git a/openwrt/package/rrdtool/Makefile b/openwrt/package/rrdtool/Makefile
deleted file mode 100644
index 3bea4aa9a6..0000000000
--- a/openwrt/package/rrdtool/Makefile
+++ /dev/null
@@ -1,111 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=rrdtool
-PKG_VERSION:=1.2.11
-PKG_RELEASE:=1
-PKG_MD5SUM:=d61c5755cb77207f9ad3584b26e8bf08
-
-PKG_SOURCE_URL:=http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,LIBRRD,librrd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,RRDCGI,rrdcgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,RRDTOOL,rrdtool,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include/freetype2 -I$(STAGING_DIR)/usr/include/libart-2.0" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib " \
- LIBS="-lnotimpl" \
- PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
- rd_cv_ieee_works=yes \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- $(DISABLE_NLS) \
- $(DISABLE_LARGEFILE) \
- --enable-shared=yes \
- --enable-static=yes \
- --disable-rpath \
- --with-gnu-ld \
- --enable-rrdcgi \
- --disable-mmap \
- --disable-perl \
- --disable-tcl \
- --disable-python \
- --without-x \
- --with-rrd-default-font=/usr/share/rrdtool/fonts/DejaVuSansMono-Roman.ttf \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
- touch $@
-
-$(IPKG_RRDTOOL):
- install -d -m0755 $(IDIR_RRDTOOL)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/rrdtool $(IDIR_RRDTOOL)/usr/bin/
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/rrdupdate $(IDIR_RRDTOOL)/usr/bin/
- $(RSTRIP) $(IDIR_RRDTOOL)
- $(IPKG_BUILD) $(IDIR_RRDTOOL) $(PACKAGE_DIR)
-
-$(IPKG_RRDCGI):
- install -d -m0755 $(IDIR_RRDCGI)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/rrdcgi $(IDIR_RRDCGI)/usr/bin/
- $(RSTRIP) $(IDIR_RRDCGI)
- $(IPKG_BUILD) $(IDIR_RRDCGI) $(PACKAGE_DIR)
-
-$(IPKG_LIBRRD):
- install -d -m0755 $(IDIR_LIBRRD)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/librrd.so.* $(IDIR_LIBRRD)/usr/lib/
- install -d -m0755 $(IDIR_LIBRRD)/usr/share/rrdtool/fonts
- $(CP) $(PKG_BUILD_DIR)/src/DejaVuSansMono-Roman.ttf \
- $(IDIR_LIBRRD)/usr/share/rrdtool/fonts/
- $(RSTRIP) $(IDIR_LIBRRD)
- $(IPKG_BUILD) $(IDIR_LIBRRD) $(PACKAGE_DIR)
-
-$(STAGING_DIR)/usr/lib/librrd.so: $(PKG_BUILD_DIR)/.built
- mkdir -p $(STAGING_DIR)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/rrd.h $(STAGING_DIR)/usr/include/
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/librrd.a $(STAGING_DIR)/usr/lib/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/librrd.so* $(STAGING_DIR)/usr/lib/
- touch $@
-
-install-dev: $(STAGING_DIR)/usr/lib/librrd.so
-
-uninstall-dev:
- rm -rf \
- $(STAGING_DIR)/usr/include/rrd.h \
- $(STAGING_DIR)/usr/lib/librrd.a \
- $(STAGING_DIR)/usr/lib/librrd.so* \
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
diff --git a/openwrt/package/rrdtool/ipkg/librrd.control b/openwrt/package/rrdtool/ipkg/librrd.control
deleted file mode 100644
index fe34716ba1..0000000000
--- a/openwrt/package/rrdtool/ipkg/librrd.control
+++ /dev/null
@@ -1,14 +0,0 @@
-Package: librrd
-Priority: optional
-Section: libs
-Depends: libart, libfreetype, libpng, zlib
-Description: Round Robin Database (RRD) management library.
- RRD is the Acronym for Round Robin Database. RRD is a system to store and
- display time-series data (i.e. network bandwidth, machine-room temperature,
- server load average). It stores the data in a very compact way that will
- not expand over time, and it presents useful graphs by processing the data
- to enforce a certain data density. It can be used either via simple wrapper
- scripts (from shell or Perl) or via frontends that poll network devices and
- put friendly user interface on it.
- .
- This package contains the shared library used to manage RRDs.
diff --git a/openwrt/package/rrdtool/ipkg/rrdcgi.control b/openwrt/package/rrdtool/ipkg/rrdcgi.control
deleted file mode 100644
index ca0f7cacd9..0000000000
--- a/openwrt/package/rrdtool/ipkg/rrdcgi.control
+++ /dev/null
@@ -1,15 +0,0 @@
-Package: rrdcgi
-Priority: optional
-Section: web
-Depends: cgilib, librrd
-Description: Round Robin Database (RRD) CGI graphing tool.
- RRD is the Acronym for Round Robin Database. RRD is a system to store and
- display time-series data (i.e. network bandwidth, machine-room temperature,
- server load average). It stores the data in a very compact way that will
- not expand over time, and it presents useful graphs by processing the data
- to enforce a certain data density. It can be used either via simple wrapper
- scripts (from shell or Perl) or via frontends that poll network devices and
- put friendly user interface on it.
- .
- This package contains the rrdcgi tool used to create web pages containing
- RRD graphs based on templates.
diff --git a/openwrt/package/rrdtool/ipkg/rrdtool.control b/openwrt/package/rrdtool/ipkg/rrdtool.control
deleted file mode 100644
index 6e273331b4..0000000000
--- a/openwrt/package/rrdtool/ipkg/rrdtool.control
+++ /dev/null
@@ -1,14 +0,0 @@
-Package: rrdtool
-Priority: optional
-Section: admin
-Depends: librrd
-Description: Round Robin Database (RRD) management tools.
- RRD is the Acronym for Round Robin Database. RRD is a system to store and
- display time-series data (i.e. network bandwidth, machine-room temperature,
- server load average). It stores the data in a very compact way that will
- not expand over time, and it presents useful graphs by processing the data
- to enforce a certain data density. It can be used either via simple wrapper
- scripts (from shell or Perl) or via frontends that poll network devices and
- put friendly user interface on it.
- .
- This package contains command line tools used to manage RRDs.