summaryrefslogtreecommitdiff
path: root/tools/elftosb/Makefile
diff options
context:
space:
mode:
authorwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-10-14 19:45:31 +0000
committerwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-10-14 19:45:31 +0000
commitdda6e8a8a3e33eafe8d131a21d54027b4288646d (patch)
tree4f5dac38d54a0d7406c025382dad885125758d45 /tools/elftosb/Makefile
parenta91083e2281b038386c4e0e4ad1f42663230668a (diff)
[tools] elftosb: support static linking
Signed-off-by: Michael Heimpold <mhei@heimpold.de> Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38400 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/elftosb/Makefile')
-rw-r--r--tools/elftosb/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/tools/elftosb/Makefile b/tools/elftosb/Makefile
index c063217d0b..6f9b963975 100644
--- a/tools/elftosb/Makefile
+++ b/tools/elftosb/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -13,19 +13,14 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://repository.timesys.com/buildsources/e/elftosb/elftosb-10.12.01/
PKG_MD5SUM:=e8005d606c1e0bb3507c82f6eceb3056
-HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)
-
include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
- $(MAKE) -C $(HOST_BUILD_DIR) -f makefile LDFLAGS="$(HOST_STATIC_LINKING)"
+ $(MAKE) -C $(HOST_BUILD_DIR) LDFLAGS="$(HOST_LDFLAGS) $(HOST_STATIC_LINKING)"
endef
define Host/Install
$(INSTALL_BIN) $(HOST_BUILD_DIR)/bld/linux/elftosb $(STAGING_DIR_HOST)/bin/elftosb
endef
-define Host/Clean
-endef
-
$(eval $(call HostBuild))