summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-08-14 13:02:29 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-08-14 13:02:29 +0000
commita92f00467e516bc8526cbd7d16e8e31cbcd42b2e (patch)
treef0eedc5fad943b44693a84a35e5c58140e6c5919 /toolchain
parent48dcd5a1168aa8a2b89fc66ad7fc190350b96b66 (diff)
build: decouple the mips16 support flag from the toolchain
Add the flags from package.mk instead, and leave libc and gcc unaffected. Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37770 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/uClibc/common.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/toolchain/uClibc/common.mk b/toolchain/uClibc/common.mk
index f0a5b3d84f..69ac470b02 100644
--- a/toolchain/uClibc/common.mk
+++ b/toolchain/uClibc/common.mk
@@ -45,8 +45,6 @@ GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
$(if $(CONFIG_MIPS64_ABI),.$(subst ",,$(CONFIG_MIPS64_ABI)), \
$(if $(CONFIG_HAS_SPE_FPU),$(if $(wildcard $(CONFIG_DIR)/$(ARCH).e500),.e500)))))
-TARGET_CFLAGS := $(filter-out -mips16,$(TARGET_CFLAGS))
-
CPU_CFLAGS = \
-funsigned-char -fno-builtin -fno-asm \
--std=gnu99 -ffunction-sections -fdata-sections \