summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-07-24 12:38:09 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-07-24 12:38:09 +0000
commitc9113d56b3ca7fe42b61a4e50c38bbf471adaad8 (patch)
tree8987adc95c31c84df0a9cdf368c633b4d2e8d68b /toolchain
parent7f63e3ede7c91b5534fe14d51039606fae9ff1a2 (diff)
uClibc: build with debug symbols by default (without changing other compile related flags)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37525 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/uClibc/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/uClibc/common.mk b/toolchain/uClibc/common.mk
index dec4a1c741..f0a5b3d84f 100644
--- a/toolchain/uClibc/common.mk
+++ b/toolchain/uClibc/common.mk
@@ -51,7 +51,7 @@ CPU_CFLAGS = \
-funsigned-char -fno-builtin -fno-asm \
--std=gnu99 -ffunction-sections -fdata-sections \
-Wno-unused-but-set-variable \
- $(TARGET_CFLAGS)
+ $(TARGET_CFLAGS) -ggdb
UCLIBC_MAKE = PATH='$(TOOLCHAIN_DIR)/initial/bin:$(TARGET_PATH)' $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \