summaryrefslogtreecommitdiff
path: root/toolchain/uClibc
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-06-30 07:54:51 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-06-30 07:54:51 +0000
commite462980421b5295b8334f83da4e2b1db7866094a (patch)
tree664143f0182487bc2ea3b53b7fdddbae3db7d6f4 /toolchain/uClibc
parenta1ae30efe40a0c929f2b5ad9da8a7804db014abb (diff)
uClibc: use position independent code for crt1, slightly reduces size of all executables
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37096 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/uClibc')
-rw-r--r--toolchain/uClibc/patches-0.9.33.2/210-mips_use_pic_crt1.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/toolchain/uClibc/patches-0.9.33.2/210-mips_use_pic_crt1.patch b/toolchain/uClibc/patches-0.9.33.2/210-mips_use_pic_crt1.patch
new file mode 100644
index 0000000000..2ca10d47cc
--- /dev/null
+++ b/toolchain/uClibc/patches-0.9.33.2/210-mips_use_pic_crt1.patch
@@ -0,0 +1,11 @@
+--- a/libc/sysdeps/linux/mips/Makefile.arch
++++ b/libc/sysdeps/linux/mips/Makefile.arch
+@@ -20,6 +20,8 @@ ifneq ($(UCLIBC_HAS_THREADS_NATIVE),y)
+ SSRC += vfork.S clone.S
+ endif
+
++CFLAGS-crt1.S += $(PICFLAG)
++
+ ASFLAGS-syscall_error.S += -D_LIBC_REENTRANT
+
+ ARCH_HEADERS := sgidefs.h