summaryrefslogtreecommitdiff
path: root/toolchain/musl/patches-0.9.11/000-install_portability.patch
diff options
context:
space:
mode:
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-07-04 21:26:01 +0000
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-07-04 21:26:01 +0000
commit5f0b225d3870eaa07b481c63c429c7cc037ac2d9 (patch)
tree8d06eadc9e21e54a86457ab90473a590b96bef73 /toolchain/musl/patches-0.9.11/000-install_portability.patch
parent30d7a005185f382c959367f4b7e69ed8c1ce90e1 (diff)
toolchain/musl: add version 0.9.11
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37173 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'toolchain/musl/patches-0.9.11/000-install_portability.patch')
-rw-r--r--toolchain/musl/patches-0.9.11/000-install_portability.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/toolchain/musl/patches-0.9.11/000-install_portability.patch b/toolchain/musl/patches-0.9.11/000-install_portability.patch
new file mode 100644
index 0000000000..43c43519d9
--- /dev/null
+++ b/toolchain/musl/patches-0.9.11/000-install_portability.patch
@@ -0,0 +1,27 @@
+--- a/Makefile
++++ b/Makefile
+@@ -116,16 +116,20 @@
+ chmod +x $@
+
+ $(DESTDIR)$(bindir)/%: tools/%
+- install -D $< $@
++ mkdir -p $(dir $@)
++ install $< $@
+
+ $(DESTDIR)$(libdir)/%.so: lib/%.so
+- install -D -m 755 $< $@
++ mkdir -p $(dir $@)
++ install -m 755 $< $@
+
+ $(DESTDIR)$(libdir)/%: lib/%
+- install -D -m 644 $< $@
++ mkdir -p $(dir $@)
++ install -m 644 $< $@
+
+ $(DESTDIR)$(includedir)/%: include/%
+- install -D -m 644 $< $@
++ mkdir -p $(dir $@)
++ install -m 644 $< $@
+
+ $(DESTDIR)$(LDSO_PATHNAME): $(DESTDIR)$(syslibdir)
+ ln -sf $(libdir)/libc.so $@ || true