summaryrefslogtreecommitdiff
path: root/target
diff options
context:
space:
mode:
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-12-17 22:14:13 +0000
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-12-17 22:14:13 +0000
commitacdf075d371c1f4bc7675b1277eb40d3d063b99a (patch)
treea63069f733fa4283a0fcefd4d0755326ba818d30 /target
parent864a6ec9731106bcd6dfdc7557f1af90ffe6f064 (diff)
ar71xx: enable images for WD My Net N750
Now that the switch works correctly we can enable the images for this board. Flashing from the factory firmware, the factory failsafe loader and sysupgrade was tested successfully. Signed-off-by: Felix Kaechele <heffer@fedoraproject.org> Patchwork: http://patchwork.openwrt.org/patch/4617/ Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39130 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/generic/profiles/wd.mk9
-rw-r--r--target/linux/ar71xx/image/Makefile1
2 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/wd.mk b/target/linux/ar71xx/generic/profiles/wd.mk
index badee449f1..b8cb99b94e 100644
--- a/target/linux/ar71xx/generic/profiles/wd.mk
+++ b/target/linux/ar71xx/generic/profiles/wd.mk
@@ -15,6 +15,15 @@ define Profile/MYNETN600/Description
endef
$(eval $(call Profile,MYNETN600))
+define Profile/MYNETN750
+ NAME:=WD My Net N750
+ PACKAGES:=kmod-usb-core kmod-usb2
+endef
+define Profile/MYNETN750/Description
+ Package set optimized for the WD My Net N750 device.
+endef
+
+$(eval $(call Profile,MYNETN750))
define Profile/MYNETREXT
NAME:=WD My Net Wi-Fi Range Extender
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 721860a50b..412caddb7c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -955,6 +955,7 @@ $(eval $(call SingleProfile,Planex,64kraw,MZKW04NU,mzk-w04nu,MZK-W04NU,ttyS0,115
$(eval $(call SingleProfile,Planex,64kraw,MZKW300NH,mzk-w300nh,MZK-W300NH,ttyS0,115200))
$(eval $(call SingleProfile,Seama,64k,MYNETN600,mynet-n600,MYNET-N600,ttyS0,115200,$$(mynet_n600_mtdlayout),wrgnd16_wd_db600,1310720,16187392))
+$(eval $(call SingleProfile,Seama,64k,MYNETN750,mynet-n750,MYNET-N750,ttyS0,115200,$$(mynet_n600_mtdlayout),wrgnd13_wd_av,1310720,16187392))
$(eval $(call SingleProfile,TPLINKOLD,squashfs-only,TLWR841NV15,tl-wr841nd-v1.5,TL-WR841N-v1.5,ttyS0,115200,0x08410002,2,4M))