summaryrefslogtreecommitdiff
path: root/target/linux/ubicom32/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2009-08-21 22:32:31 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2009-08-21 22:32:31 +0000
commitf48e79cafe9d99bc741c905cb8328cc54cb75f6d (patch)
treed01d05b694c1dfcde7b1e9873adbeeb1b8a56809 /target/linux/ubicom32/Makefile
parentef51dee11cd047ffa7aa037541423d115ea6bef5 (diff)
add a new target for ubicom32 (compiles, but untested)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17350 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ubicom32/Makefile')
-rw-r--r--target/linux/ubicom32/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ubicom32/Makefile b/target/linux/ubicom32/Makefile
new file mode 100644
index 0000000000..7bdbd204e8
--- /dev/null
+++ b/target/linux/ubicom32/Makefile
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+#Add target specific (nommu) flags
+TARGET_CFLAGS+= -DNO_FORK
+
+ARCH:=ubicom32
+BOARD:=ubicom32
+BOARDNAME:=Ubicom IPxx
+FEATURES:=nommu
+
+LINUX_VERSION:=2.6.28.10
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNEL_MAKEOPTS += LDFLAGS_BUILD_ID=""
+
+define Target/Description
+ Build firmware images for Ubicom based routers and media devices.
+endef
+
+$(eval $(call BuildTarget))