summaryrefslogtreecommitdiff
path: root/target/linux/olpc/files-2.6.23/include/asm-i386/ofw.h
diff options
context:
space:
mode:
authorryd <ryd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2008-02-19 04:03:49 +0000
committerryd <ryd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2008-02-19 04:03:49 +0000
commite4a3634c00818e77664da2c3592a95e8c8fad5d6 (patch)
tree5aec8287ecd3034c53cbbeb5a6408389b1d34507 /target/linux/olpc/files-2.6.23/include/asm-i386/ofw.h
parentac24192a897d17c7416cfc1a58ad5432404662de (diff)
Adding .24 support for olpc
kernel compiles fine, but graphic support is broken to test new kernel version, change target/linux/olpc/Makefile from .23.16 to .24 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10493 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/olpc/files-2.6.23/include/asm-i386/ofw.h')
-rw-r--r--target/linux/olpc/files-2.6.23/include/asm-i386/ofw.h16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/olpc/files-2.6.23/include/asm-i386/ofw.h b/target/linux/olpc/files-2.6.23/include/asm-i386/ofw.h
new file mode 100644
index 0000000000..79b08b164f
--- /dev/null
+++ b/target/linux/olpc/files-2.6.23/include/asm-i386/ofw.h
@@ -0,0 +1,16 @@
+/*
+ * Definitions for Open Firmware client interface on 32-bit system.
+ * OF Cell size is 4. Integer properties are encoded big endian,
+ * as with all OF implementations.
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version
+ * 2 of the License, or (at your option) any later version.
+ */
+#ifndef _OFW_H
+#define _OFW_H
+
+extern int ofw(char *, int, int, ...);
+
+#endif