summaryrefslogtreecommitdiff
path: root/target/linux/mvebu
diff options
context:
space:
mode:
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-01-15 18:38:51 +0000
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-01-15 18:38:51 +0000
commit33c227f41e07c96e1ed9e27f9251886deb8bfea2 (patch)
tree3c4990b99ac57ddfc15b7de445794578ac567bc6 /target/linux/mvebu
parent9da84d6a237785d3dedbc6de3cca37713cee1ec4 (diff)
mvebu: fix build failures when initramfs is not selected
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39301 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mvebu')
-rw-r--r--target/linux/mvebu/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index af29c2baae..1e4a7910e3 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -30,7 +30,9 @@ endef
define Image/BuildKernel
$(foreach dtb,$(TARGET_DTBS),$(call Image/Build/DTB,$(dtb)))
+ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
$(call Image/Build/Initramfs)
+ endif
endef
define Image/Build/squashfs