summaryrefslogtreecommitdiff
path: root/target/linux/iop32x
diff options
context:
space:
mode:
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-06-27 19:58:31 +0000
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-06-27 19:58:31 +0000
commit40b6cba8e4c4f053cd423a38e29c06fd2a27cb21 (patch)
treeffba1790b89941519ddb5acc2bf8f55df6b65529 /target/linux/iop32x
parent56630ce61e5d3774a7f3d62de80a77c460df2776 (diff)
targets: prepare for supporting normal and initramfs images
In order to support both normal images and initramfs, ensure that each target sets KERNELNAME properly so that the generic kernel building code can copy the corresponding files over $(KDIR) with the appropriate extension. Update the various paths to the kernel and wrapper images from $(LINUX_DIR)/arch/$(ARCH)/boot/$(foo) to $(KDIR)/$(foo). Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37049 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/iop32x')
-rw-r--r--target/linux/iop32x/Makefile2
-rw-r--r--target/linux/iop32x/image/Makefile4
2 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/iop32x/Makefile b/target/linux/iop32x/Makefile
index 90bdc6f2eb..8c66387e6b 100644
--- a/target/linux/iop32x/Makefile
+++ b/target/linux/iop32x/Makefile
@@ -16,4 +16,6 @@ LINUX_VERSION:=3.3.8
include $(INCLUDE_DIR)/target.mk
+KERNELNAME:="zImage"
+
$(eval $(call BuildTarget))
diff --git a/target/linux/iop32x/image/Makefile b/target/linux/iop32x/image/Makefile
index 160067386d..0df51ba5cb 100644
--- a/target/linux/iop32x/image/Makefile
+++ b/target/linux/iop32x/image/Makefile
@@ -7,10 +7,6 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define Image/Prepare
- cp $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/zImage
-endef
-
define Image/BuildKernel
cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
#