summaryrefslogtreecommitdiff
path: root/target/linux/generic/patches-3.7/832-ledtrig_usbdev.patch
diff options
context:
space:
mode:
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-07-20 07:37:27 +0000
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-07-20 07:37:27 +0000
commite318c8672daf354c23c3da9dc4239636ff4901ee (patch)
tree5f4a31a2b4ea39aab41f28580fbf13fc0f7976f8 /target/linux/generic/patches-3.7/832-ledtrig_usbdev.patch
parentce6f13f13faa70bf770a6edd81ea2500d5c8263e (diff)
linux: remove 3.7 support
It is not used by any target. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37469 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.7/832-ledtrig_usbdev.patch')
-rw-r--r--target/linux/generic/patches-3.7/832-ledtrig_usbdev.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/target/linux/generic/patches-3.7/832-ledtrig_usbdev.patch b/target/linux/generic/patches-3.7/832-ledtrig_usbdev.patch
deleted file mode 100644
index 5bf6157989..0000000000
--- a/target/linux/generic/patches-3.7/832-ledtrig_usbdev.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/drivers/leds/Kconfig
-+++ b/drivers/leds/Kconfig
-@@ -570,4 +570,11 @@ config LEDS_TRIGGER_NETDEV
- This allows LEDs to be controlled by network device activity.
- If unsure, say Y.
-
-+config LEDS_TRIGGER_USBDEV
-+ tristate "LED USB device Trigger"
-+ depends on USB && LEDS_TRIGGERS
-+ help
-+ This allows LEDs to be controlled by the presence/activity of
-+ an USB device. If unsure, say N.
-+
- endif # NEW_LEDS
---- a/drivers/leds/Makefile
-+++ b/drivers/leds/Makefile
-@@ -67,3 +67,4 @@ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) +=
- obj-$(CONFIG_LEDS_TRIGGER_TRANSIENT) += ledtrig-transient.o
- obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
- obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
-+obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
---- a/drivers/leds/ledtrig-usbdev.c
-+++ b/drivers/leds/ledtrig-usbdev.c
-@@ -24,7 +24,6 @@
- #include <linux/list.h>
- #include <linux/spinlock.h>
- #include <linux/device.h>
--#include <linux/sysdev.h>
- #include <linux/timer.h>
- #include <linux/ctype.h>
- #include <linux/slab.h>