summaryrefslogtreecommitdiff
path: root/target/linux/generic/patches-3.12/700-swconfig.patch
diff options
context:
space:
mode:
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-10-24 13:50:11 +0000
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-10-24 13:50:11 +0000
commit62a2176cb1446f865b58299f080493f26ce53573 (patch)
tree4613cca2c570d5eefc520620ba3bac85f7015a4b /target/linux/generic/patches-3.12/700-swconfig.patch
parent844db040b986ac718bf6a7732e1dcd770de0f727 (diff)
[generic:] preliminary 3.12 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38528 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.12/700-swconfig.patch')
-rw-r--r--target/linux/generic/patches-3.12/700-swconfig.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.12/700-swconfig.patch b/target/linux/generic/patches-3.12/700-swconfig.patch
new file mode 100644
index 0000000000..0e1774737c
--- /dev/null
+++ b/target/linux/generic/patches-3.12/700-swconfig.patch
@@ -0,0 +1,39 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -12,6 +12,16 @@ menuconfig PHYLIB
+
+ if PHYLIB
+
++config SWCONFIG
++ tristate "Switch configuration API"
++ ---help---
++ Switch configuration API using netlink. This allows
++ you to configure the VLAN features of certain switches.
++
++config SWCONFIG_LEDS
++ bool "Switch LED trigger support"
++ depends on (SWCONFIG && LEDS_TRIGGERS)
++
+ comment "MII PHY device drivers"
+
+ config AT803X_PHY
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -3,6 +3,7 @@
+ libphy-objs := phy.o phy_device.o mdio_bus.o
+
+ obj-$(CONFIG_PHYLIB) += libphy.o
++obj-$(CONFIG_SWCONFIG) += swconfig.o
+ obj-$(CONFIG_MARVELL_PHY) += marvell.o
+ obj-$(CONFIG_DAVICOM_PHY) += davicom.o
+ obj-$(CONFIG_CICADA_PHY) += cicada.o
+--- a/include/uapi/linux/Kbuild
++++ b/include/uapi/linux/Kbuild
+@@ -364,6 +364,7 @@ header-y += stddef.h
+ header-y += string.h
+ header-y += suspend_ioctls.h
+ header-y += swab.h
++header-y += switch.h
+ header-y += synclink.h
+ header-y += sysctl.h
+ header-y += sysinfo.h