summaryrefslogtreecommitdiff
path: root/target/linux/au1000
diff options
context:
space:
mode:
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-06-27 19:58:31 +0000
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-06-27 19:58:31 +0000
commit40b6cba8e4c4f053cd423a38e29c06fd2a27cb21 (patch)
treeffba1790b89941519ddb5acc2bf8f55df6b65529 /target/linux/au1000
parent56630ce61e5d3774a7f3d62de80a77c460df2776 (diff)
targets: prepare for supporting normal and initramfs images
In order to support both normal images and initramfs, ensure that each target sets KERNELNAME properly so that the generic kernel building code can copy the corresponding files over $(KDIR) with the appropriate extension. Update the various paths to the kernel and wrapper images from $(LINUX_DIR)/arch/$(ARCH)/boot/$(foo) to $(KDIR)/$(foo). Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37049 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/au1000')
-rw-r--r--target/linux/au1000/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/au1000/image/Makefile b/target/linux/au1000/image/Makefile
index a2f2056d4f..1dfdd9843c 100644
--- a/target/linux/au1000/image/Makefile
+++ b/target/linux/au1000/image/Makefile
@@ -51,7 +51,7 @@ define Image/Prepare
endef
define Image/Build/Initramfs
- $(OBJCOPY_SREC) $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.srec
+ $(OBJCOPY_SREC) $(KDIR)/vmlinux-initramfs.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs.srec
endef
define Image/Build