summaryrefslogtreecommitdiff
path: root/target/linux/ar71xx
diff options
context:
space:
mode:
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-02-13 21:19:00 +0000
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-02-13 21:19:00 +0000
commit460d0bf686dd0ec96269bdf13f83d8a1e62e9ba7 (patch)
treec1ec7bfba60af681ffe461650c37d43293251bf4 /target/linux/ar71xx
parent340b5931de182bbeb9715f956e6146e0bc85811b (diff)
ar71xx: fix mtdpartsize macro in image Makefile (#14961)
The mtdpartsize macro triggers shell errors on various Linux distributions when the partname argument $(1) does not appear within the partmap $(2). Change the sed pattern to only emit anything if a successful substitution occured and only evaluate the arithmetic expression if something was printed by the sed program. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39583 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx')
-rw-r--r--target/linux/ar71xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 1f181f4ce2..9076f22ff0 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -36,7 +36,7 @@ $(if $(1),board=$(1) )$(if $(2),console=$(2)$(COMMA)$(3))
endef
define mtdpartsize
-$(shell echo $$((`echo '$(2)' | sed -e 's/.*[:$(COMMA)]\([0-9]*\)k[@]*[0-9a-zx]*($(1)).*/\1/'` * 1024)))
+$(shell sz=`echo '$(2)' | sed -ne 's/.*[:$(COMMA)]\([0-9]*\)k[@]*[0-9a-zx]*($(1)).*/\1/p'`; [ -n "$$sz" ] && echo $$(($$sz * 1024)))
endef
SINGLE_PROFILES:=