summaryrefslogtreecommitdiff
path: root/target/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-13 20:51:49 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-13 20:51:49 +0000
commitf52d66ff00b24111f87c274d3d7085ef2e1d27b1 (patch)
treed993cf48b4d89166701fe2f33976389d7634235d /target/Makefile
parent725611a466f2edf12f809d22339b22223af4afe7 (diff)
parent0c0df9eb082d5ff83d0f22f6e00bf580729fb49d (diff)
finally move buildroot-ng to trunk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5059 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/Makefile')
-rw-r--r--target/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/target/Makefile b/target/Makefile
new file mode 100644
index 0000000000..195878e665
--- /dev/null
+++ b/target/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/target.mk
+
+all: install
+
+$(BIN_DIR):
+ mkdir -p $(BIN_DIR)
+
+TARGETS-y := linux utils
+TARGETS-$(CONFIG_SDK) += sdk
+
+linux-compile: utils-install
+linux-install: $(BIN_DIR)
+sdk-compile: linux-install
+image_install: linux-install
+
+download: $(patsubst %,%-download,$(TARGETS-y))
+prepare: linux-prepare
+compile: linux-compile image_compile
+install: image_clean $(patsubst %,%-install,$(TARGETS-y)) image_install
+clean: $(patsubst %,%-clean,$(TARGETS-y)) image_clean
+
+image_clean: FORCE
+ $(MAKE) -C image/$(BOARD) clean
+ rm -f $(BIN_DIR)/openwrt-*
+
+image_compile: FORCE
+ $(MAKE) -C image/$(BOARD) compile
+
+image_install: image_compile
+ $(MAKE) -C image/$(BOARD) install
+
+%-clean: FORCE
+ $(MAKE) -C $(patsubst %-clean,%,$@) clean
+%-download: FORCE
+ $(MAKE) -C $(patsubst %-download,%,$@) download
+%-prepare: FORCE
+ $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
+%-compile: %-prepare
+ $(MAKE) -C $(patsubst %-compile,%,$@) compile
+%-install: %-compile
+ $(MAKE) -C $(patsubst %-install,%,$@) install
+