summaryrefslogtreecommitdiff
path: root/rules.mk
diff options
context:
space:
mode:
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-11-29 10:59:51 +0000
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-11-29 10:59:51 +0000
commit766b301ea3abb89e455fd80f41c4b19d50f6cbc6 (patch)
treeb82c67596a543545aa3bdd656a90c4eeb8fd7d48 /rules.mk
parent90ab65b8496c9f7052d3207fd2de7bcc44e61547 (diff)
FPU type should not interfere with the ABI selection.
Also make sure we either do real soft-float or hard-float on ARM, with the right options. Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38943 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/rules.mk b/rules.mk
index 80e07d11a2..47ba928de5 100644
--- a/rules.mk
+++ b/rules.mk
@@ -168,9 +168,16 @@ TARGET_PATH_PKG:=$(STAGING_DIR)/host/bin:$(TARGET_PATH)
ifeq ($(CONFIG_SOFT_FLOAT),y)
SOFT_FLOAT_CONFIG_OPTION:=--with-float=soft
- TARGET_CFLAGS+= -msoft-float
+ ifeq ($(CONFIG_arm),y)
+ TARGET_CFLAGS+= -mfloat-abi=soft
+ else
+ TARGET_CFLAGS+= -msoft-float
+ endif
else
SOFT_FLOAT_CONFIG_OPTION:=
+ ifeq ($(CONFIG_arm),y)
+ TARGET_CFLAGS+= -mfloat-abi=hard
+ endif
endif
export PATH:=$(TARGET_PATH)