summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-11-11 12:18:58 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-11-11 12:18:58 +0000
commit32c284096796454b474c70667c0f85e64ddf82d0 (patch)
tree980ced70d04e2827bf5fd57cb6bcf2613ae8bda7 /package
parentd6ade39269847e5af8b75105c88be615e12e291d (diff)
uhttp: make sure that the ubus module is loaded when when installed
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38723 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/network/services/uhttpd/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 2ff2ff798c..be1a1e27f1 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -129,8 +129,9 @@ define Package/uhttpd-mod-lua/install
endef
define Package/uhttpd-mod-ubus/install
- $(INSTALL_DIR) $(1)/usr/lib
+ $(INSTALL_DIR) $(1)/usr/lib $(1)/etc/uci-defaults
$(INSTALL_BIN) $(PKG_BUILD_DIR)/uhttpd_ubus.so $(1)/usr/lib/
+ $(INSTALL_DATA) ./files/ubus.default $(1)/etc/uci-defaults/00_uhttpd_ubus
endef