summaryrefslogtreecommitdiff
path: root/package/zram-swap/Makefile
diff options
context:
space:
mode:
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-06-21 16:54:37 +0000
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-06-21 16:54:37 +0000
commit4d953d3a481dd847524eae78c7aae00153bc7efd (patch)
tree37c9cbe251e4fb790aaa72e862c35822be30b491 /package/zram-swap/Makefile
parent801985e5286881dd578a19280b2a6c8e212a530d (diff)
packages: clean up the package folder
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37007 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/zram-swap/Makefile')
-rw-r--r--package/zram-swap/Makefile46
1 files changed, 0 insertions, 46 deletions
diff --git a/package/zram-swap/Makefile b/package/zram-swap/Makefile
deleted file mode 100644
index bded5f3808..0000000000
--- a/package/zram-swap/Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=zram-swap
-PKG_VERSION:=1
-PKG_RELEASE:=2
-
-PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/zram-swap
- SECTION:=utils
- CATEGORY:=Base system
- DEPENDS:=+kmod-zram +!(BUSYBOX_CONFIG_MKSWAP&&BUSYBOX_CONFIG_SWAPONOFF):swap-utils
- TITLE:=ZRAM swap scripts
- PKGARCH:=all
-endef
-
-define Package/zram-swap/description
- A script to activate swaping on a compressed zram partition. This
- could be used to increase the available memory, by using compressed
- memory.
-endef
-
-define Build/Prepare
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-define Package/zram-swap/install
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/zram.init $(1)/etc/init.d/zram
-endef
-
-$(eval $(call BuildPackage,zram-swap))