summaryrefslogtreecommitdiff
path: root/package/uboot-lantiq/Makefile
diff options
context:
space:
mode:
authorralph <ralph@3c298f89-4303-0410-b956-a3cf2f4a3e73>2010-03-30 13:49:42 +0000
committerralph <ralph@3c298f89-4303-0410-b956-a3cf2f4a3e73>2010-03-30 13:49:42 +0000
commited42a8a32363683414d3aeba3bbbd242831b6adb (patch)
treebef9924b410ab5a30f1b5d41c30e844404a90d58 /package/uboot-lantiq/Makefile
parent0f85365209e075c6969b4157eb1137be37ccaeeb (diff)
adding httpd - failsafe patch
flash write routine is not functional yet add configuration (board & dram) git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20603 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/uboot-lantiq/Makefile')
-rw-r--r--package/uboot-lantiq/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/package/uboot-lantiq/Makefile b/package/uboot-lantiq/Makefile
index 3ffe8846ee..48f4683161 100644
--- a/package/uboot-lantiq/Makefile
+++ b/package/uboot-lantiq/Makefile
@@ -35,12 +35,20 @@ define Build/Prepare
find $(PKG_BUILD_DIR) -name .svn | $(XARGS) rm -rf
endef
-UBOOT_CONFIG:=easy50712_DDR166M
+UBOOT_CONFIG:=$(call qstrip,$(CONFIG_UBOOT_CONFIG))
+UBOOT_DDR_CONFIG:=$(call qstrip,$(CONFIG_UBOOT_DDR_CONFIG))
+
UBOOT_MAKE_OPTS:= \
CROSS_COMPILE=$(TARGET_CROSS) \
ENDIANNESS= \
V=1
+define Package/uboot-lantiq/config
+ menu "configuration"
+ source "$(SOURCE)/Config.in"
+ endmenu
+endef
+
define Build/Configure/Target
$(MAKE) -s -C $(PKG_BUILD_DIR) \
$(UBOOT_MAKE_OPTS) \
@@ -50,7 +58,9 @@ endef
define Build/Configure
$(call Build/Configure/Target,$(UBOOT_CONFIG))
+ifeq ($(CONFIG_UBOOT_RAMBOOT),y)
$(call Build/Configure/Target,$(UBOOT_CONFIG)_ramboot)
+endif
endef
define Build/Compile/Target
@@ -62,7 +72,9 @@ endef
define Build/Compile
$(call Build/Compile/Target,$(UBOOT_CONFIG))
+ifeq ($(CONFIG_UBOOT_RAMBOOT),y)
$(call Build/Compile/Target,$(UBOOT_CONFIG)_ramboot)
+endif
endef
define Package/uboot-lantiq/install
@@ -71,12 +83,14 @@ define Package/uboot-lantiq/install
if=$(PKG_BUILD_DIR)/$(UBOOT_CONFIG)/u-boot.bin \
of=$(1)/$(UBOOT_CONFIG)/u-boot.bin \
bs=64k conv=sync
+ifeq ($(CONFIG_UBOOT_RAMBOOT),y)
if [ -e $(UBOOT_CONFIG).conf ]; then \
perl ./gct \
- $(UBOOT_CONFIG).conf \
+ $(UBOOT_DDR_CONFIG) \
$(PKG_BUILD_DIR)/$(UBOOT_CONFIG)_ramboot/u-boot.srec \
$(1)/$(UBOOT_CONFIG)/u-boot.asc; \
fi
+endif
endef
$(eval $(call BuildPackage,uboot-lantiq))