summaryrefslogtreecommitdiff
path: root/package/linux/kernel-source/drivers/net/wl
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-28 09:17:29 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-28 09:17:29 +0000
commit76ed58d705e7f3892a1259abcd92882a527e7b53 (patch)
tree80dfa6ecb493ee8cb9ca1436f1b37ee89f320a55 /package/linux/kernel-source/drivers/net/wl
parente285af3e184318b0fefeab597ae5ee4a2628422d (diff)
move package/linux into target/linux, use wbx' new kernel code. support building images with more than one kernel, split kernel module parts off of packages that use their own kernel modules (fuse, shfs, openswan). some cleanup in the image building process in target/. image builder is disabled for now, needs some fixing.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1085 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/linux/kernel-source/drivers/net/wl')
-rw-r--r--package/linux/kernel-source/drivers/net/wl/Makefile59
1 files changed, 0 insertions, 59 deletions
diff --git a/package/linux/kernel-source/drivers/net/wl/Makefile b/package/linux/kernel-source/drivers/net/wl/Makefile
deleted file mode 100644
index 7c82e6519b..0000000000
--- a/package/linux/kernel-source/drivers/net/wl/Makefile
+++ /dev/null
@@ -1,59 +0,0 @@
-#
-# Makefile for the Broadcom wl driver
-#
-# Copyright 2004, Broadcom Corporation
-# All Rights Reserved.
-#
-# THIS SOFTWARE IS OFFERED "AS IS", AND BROADCOM GRANTS NO WARRANTIES OF ANY
-# KIND, EXPRESS OR IMPLIED, BY STATUTE, COMMUNICATION OR OTHERWISE. BROADCOM
-# SPECIFICALLY DISCLAIMS ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS
-# FOR A SPECIFIC PURPOSE OR NONINFRINGEMENT CONCERNING THIS SOFTWARE.
-#
-# $Id$
-#
-
-O_TARGET := wl.o
-
-WL_OBJS := wl_linux.o wlc.o d11ucode.o wlc_phy.o wlc_rate.o wlc_led.o wlc_security.o rc4.o tkhash.o bcmwpa.o
-
-INSUP_OBJS := aes.o aeskeywrap.o hmac.o md5.o passhash.o prf.o rijndael-alg-fst.o sha1.o
-
-# Alternate ioctl interfaces
-#ifeq ($(CONFIG_NET_WIRELESS),y)
-#WL_OBJS += wlc_cmn_ioctl.o
-#endif
-ifeq ($(CONFIG_WL_OID),y)
-WL_OBJS += wl_oid.o
-endif
-
-ifeq ($(CONFIG_WL_STA),y)
-WL_OBJS += $(INSUP_OBJS)
-endif
-
-# Prefix driver variants
-WL_APOBJS := $(foreach obj,$(WL_OBJS),ap_$(obj))
-WL_STAOBJS := $(foreach obj,$(WL_OBJS) wlc_sup.o,sta_$(obj))
-WL_APSTAOBJS := $(foreach obj,$(WL_OBJS) wlc_sup.o,apsta_$(obj))
-ifneq ($(CONFIG_WL_STA),y)
-WL_APSTAOBJS += $(foreach obj,$(INSUP_OBJS), apsta_$(obj))
-endif
-
-# Either or both
-ifeq ($(CONFIG_WL_AP),y)
-AP := AP
-endif
-ifeq ($(CONFIG_WL_STA),y)
-STA := STA
-endif
-
-# Build all variants as modules but link only one of them
-export-objs :=
-obj-y := $(WL_$(AP)$(STA)OBJS)
-obj-m := $(O_TARGET)
-variant-objs := $(WL_APOBJS) $(WL_STAOBJS) $(WL_APSTAOBJS)
-
-EXTRA_CFLAGS += -DDMA
-
-include $(TOPDIR)/Rules.make
-
-