summaryrefslogtreecommitdiff
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-09-27 20:44:11 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-09-27 20:44:11 +0000
commitef48c1a2509e6e5c4ee80cdccde991b22dce6758 (patch)
treedeb25d57062eb6780c05e0f94fbdbbae4a3f9418 /package/kernel/linux/modules
parent1ad70bb6160d2bbd3d33b8fa5a9aba98d191cdb9 (diff)
kernel: mark kmod-thermal menuconfig symbol as hidden to avoid building it on targets with no thermal drivers
Should fix build errors with Linux 3.3/3.6 targets, which use different kconfig symbols Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38238 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/other.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index cbce02bbf5..b3e268e79c 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -765,6 +765,7 @@ $(eval $(call KernelPackage,random-core))
define KernelPackage/thermal
SUBMENU:=$(OTHER_MENU)
TITLE:=Generic Thermal sysfs driver
+ HIDDEN:=1
KCONFIG:= \
CONFIG_THERMAL \
CONFIG_THERMAL_DEFAULT_GOV_STEP_WISE=y \