summaryrefslogtreecommitdiff
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-09-10 22:26:37 +0000
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-09-10 22:26:37 +0000
commit92c70e62bf62dd51702bd63dcf28fb80cb5ccc2f (patch)
tree732cd2ab9f161a384e51038bd8d5878532a05f36 /package/kernel/linux/modules
parenta7bc93bb2deac587f66c140e2265e3d3fb808873 (diff)
kernel: add imx sata module
Signed-off-by: Tim Harvey <tharvey@gateworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37937 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/block.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index a26d4538f4..c5fcb9a6e8 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -72,6 +72,24 @@ endef
$(eval $(call KernelPackage,ata-artop))
+define KernelPackage/ata-imx
+ TITLE:=Freescale i.MX6 AHCI SATA support
+ KCONFIG:=\
+ CONFIG_AHCI_IMX \
+ CONFIG_SATA_AHCI_PLATFORM \
+ CONFIG_PATA_IMX=n
+ FILES:=$(LINUX_DIR)/drivers/ata/ahci_imx.ko
+ AUTOLOAD:=$(call AutoLoad,41,ahci_imx,1)
+ $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-imx/description
+ SATA support for the Freescale i.MX6 SoC's onboard AHCI SATA
+endef
+
+$(eval $(call KernelPackage,ata-imx))
+
+
define KernelPackage/ata-marvell-sata
TITLE:=Marvell Serial ATA support
KCONFIG:=CONFIG_SATA_MV