summaryrefslogtreecommitdiff
path: root/package/boot
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-06-28 11:27:13 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-06-28 11:27:13 +0000
commit27cbb7d2a6d381d628eccc36954b04f3d580ba72 (patch)
treeef13f8c2612e7acee22548f2a560da5d90730b2c /package/boot
parente5388e2e5728a2955720bf02a5ff765de72a80fd (diff)
kexec-tools: make zlib support optional, but enabled by default
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37071 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot')
-rw-r--r--package/boot/kexec-tools/Config.in5
-rw-r--r--package/boot/kexec-tools/Makefile7
2 files changed, 10 insertions, 2 deletions
diff --git a/package/boot/kexec-tools/Config.in b/package/boot/kexec-tools/Config.in
index 60c819d798..2642171bb0 100644
--- a/package/boot/kexec-tools/Config.in
+++ b/package/boot/kexec-tools/Config.in
@@ -18,4 +18,9 @@ config KEXEC_TOOLS_kdump
help
Include the kdump utility.
+config KEXEC_ZLIB
+ bool
+ prompt "zlib support"
+ default y
+
endmenu
diff --git a/package/boot/kexec-tools/Makefile b/package/boot/kexec-tools/Makefile
index fa4f4d8efc..541dca275a 100644
--- a/package/boot/kexec-tools/Makefile
+++ b/package/boot/kexec-tools/Makefile
@@ -17,12 +17,14 @@ PKG_MD5SUM:=b3ced2097ce3981abba38ceedc84f939
PKG_FIXUP:=autoreconf
+PKG_CONFIG_DEPENDS := CONFIG_KEXEC_ZLIB
+
include $(INCLUDE_DIR)/package.mk
define Package/kexec-tools
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=@armeb||@arm||@i386||@powerpc64||@mipsel||@mips +zlib
+ DEPENDS:=@armeb||@arm||@i386||@powerpc64||@mipsel||@mips +KEXEC_ZLIB:zlib
TITLE:=Kernel boots kernel
URL:=http://kernel.org/pub/linux/kernel/people/horms/kexec-tools/
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
@@ -51,7 +53,8 @@ CONFIGURE_ARGS = \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
--libexecdir=/usr/lib \
- --sysconfdir=/etc
+ --sysconfdir=/etc \
+ $(if $(CONFIG_KEXEC_ZLIB),--with,--without)-zlib
CONFIGURE_VARS += \
BUILD_CC="$(HOSTCC)" \