summaryrefslogtreecommitdiff
path: root/package/boot/kexec-tools/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-06-28 11:27:16 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-06-28 11:27:16 +0000
commitf543847f854a3107624005b62ca6cd7623063198 (patch)
tree78b575ee74f83daf1a27607add4f2f895d29d17d /package/boot/kexec-tools/Makefile
parent27cbb7d2a6d381d628eccc36954b04f3d580ba72 (diff)
kexec-tools: reduce size
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37072 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/boot/kexec-tools/Makefile')
-rw-r--r--package/boot/kexec-tools/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/boot/kexec-tools/Makefile b/package/boot/kexec-tools/Makefile
index 541dca275a..40ba9eb525 100644
--- a/package/boot/kexec-tools/Makefile
+++ b/package/boot/kexec-tools/Makefile
@@ -56,6 +56,9 @@ CONFIGURE_ARGS = \
--sysconfdir=/etc \
$(if $(CONFIG_KEXEC_ZLIB),--with,--without)-zlib
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
+
CONFIGURE_VARS += \
BUILD_CC="$(HOSTCC)" \
TARGET_CC="$(TARGET_CC)"