summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-07 16:25:40 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-07 16:25:40 +0000
commit7310af14da98e6d37489b507842645f221b21bdd (patch)
treea22f5c9eadfce255070d39e46257b82af2cf70c8 /openwrt
parent75e43d486e96e0b284b0a47a3d1de6e04f8f14ad (diff)
fix package_index
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@339 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index 1a218df586..04a07ddbf6 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -74,7 +74,9 @@ world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install pac
.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install
package_index:
- $(STAGING_DIR)/usr/bin/ipkg-make-index $(PACKAGE_DIR) > $(PACKAGE_DIR)/Packages
+ (cd $(PACKAGE_DIR); \
+ $(STAGING_DIR)/usr/bin/ipkg-make-index . > Packages \
+ )
target_prepare:
$(MAKE) -C target prepare