summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-02-26 02:32:16 +0000
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-02-26 02:32:16 +0000
commite6a8154811ab88f040bf77410f02cde203f3a41c (patch)
tree974dde8f6003d98e97764410cbbbe1ccfe6b5138 /openwrt
parent7cef27d7518e984db79e1025bb0e2927b940ec68 (diff)
bugfix
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@294 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/Makefile2
-rw-r--r--openwrt/package/openwrt/jffs2root.c5
-rwxr-xr-xopenwrt/target/default/target_skeleton/etc/preinit6
-rw-r--r--openwrt/target/squashfs-lzma/squashfslzmaroot.mk1
-rw-r--r--openwrt/target/squashfs/squashfsroot.mk1
5 files changed, 9 insertions, 6 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index dfa272120b..b8c9b10b70 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -118,6 +118,8 @@ $(TARGET_DIR):
fi;
-find $(TARGET_DIR) -type d -name CVS | xargs rm -rf
-find $(TARGET_DIR) -type d -name .svn | xargs rm -rf
+ -ln -sf /tmp/resolv.conf $(TARGET_DIR)
+ -mkdir -p $(TARGET_DIR)/jffs
source: $(TARGETS_SOURCE)
diff --git a/openwrt/package/openwrt/jffs2root.c b/openwrt/package/openwrt/jffs2root.c
index e74c89a9ba..2ff37fdad3 100644
--- a/openwrt/package/openwrt/jffs2root.c
+++ b/openwrt/package/openwrt/jffs2root.c
@@ -48,7 +48,10 @@ void init_crc32()
unsigned long crc;
unsigned long poly = 0xEDB88320L;
int n, bit;
- crc32 = (unsigned long *) malloc(256 * sizeof(unsigned long));
+ if ((crc32 = (unsigned long *) malloc(256 * sizeof(unsigned long))) == (void *)-1) {
+ perror("malloc");
+ exit(1);
+ }
for (n = 0; n < 256; n++) {
crc = (unsigned long) n;
for (bit = 0; bit < 8; bit++)
diff --git a/openwrt/target/default/target_skeleton/etc/preinit b/openwrt/target/default/target_skeleton/etc/preinit
index d2036f4e59..28fe805260 100755
--- a/openwrt/target/default/target_skeleton/etc/preinit
+++ b/openwrt/target/default/target_skeleton/etc/preinit
@@ -11,10 +11,10 @@ else
mtd unlock mtd4
mount -t jffs2 /dev/mtdblock/4 /jffs
pivot_root /jffs /jffs/rom
- mount none /dev -t devfs
- mount none /proc -t proc
- umount rom/proc
}
+ mount none /dev -t devfs
+ mount none /proc -t proc
+ umount rom/proc
fi
mount none /tmp -t ramfs
exec /sbin/init
diff --git a/openwrt/target/squashfs-lzma/squashfslzmaroot.mk b/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
index 4059896bc9..722c20524e 100644
--- a/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
+++ b/openwrt/target/squashfs-lzma/squashfslzmaroot.mk
@@ -39,7 +39,6 @@ squashfslzma-dirclean:
squashfslzmaroot: squashfslzma
@rm -rf $(TARGET_DIR)/usr/man
@rm -rf $(TARGET_DIR)/usr/info
- @mkdir -p $(TARGET_DIR)/jffs
$(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs-lzma $(TARGET_DIR) $(IMAGE).squashfslzma -noappend -root-owned -le
squashfslzmaroot-source: squashfslzma-source
diff --git a/openwrt/target/squashfs/squashfsroot.mk b/openwrt/target/squashfs/squashfsroot.mk
index 62b645a883..d3a104a83f 100644
--- a/openwrt/target/squashfs/squashfsroot.mk
+++ b/openwrt/target/squashfs/squashfsroot.mk
@@ -38,7 +38,6 @@ squashfs-dirclean:
squashfsroot: squashfs
@rm -rf $(TARGET_DIR)/usr/man
@rm -rf $(TARGET_DIR)/usr/info
- @mkdir -p $(TARGET_DIR)/jffs
$(SQUASHFS_DIR)/squashfs-tools/mksquashfs $(TARGET_DIR) $(IMAGE).squashfs -noappend -root-owned -le
squashfsroot-source: squashfs-source