summaryrefslogtreecommitdiff
path: root/openwrt/toolchain
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-29 09:51:34 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-29 09:51:34 +0000
commit045896f4743bf3ff044960b106bdf0f39310000a (patch)
treed4945dce3757008920f3e038c754516c5ea95953 /openwrt/toolchain
parent35cbf0d9385af66d9ab2dad3facba3e1845ae5a7 (diff)
make gcc compile install libgcc_s by default, remove package/libgcc/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@755 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/toolchain')
-rw-r--r--openwrt/toolchain/gcc/gcc-uclibc-3.x.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/openwrt/toolchain/gcc/gcc-uclibc-3.x.mk b/openwrt/toolchain/gcc/gcc-uclibc-3.x.mk
index e719b87140..c7f9495034 100644
--- a/openwrt/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/openwrt/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -203,6 +203,9 @@ ifeq ($(findstring 3.3.,$(GCC_VERSION)),3.3.)
cp ./$(GCC_VERSION)/specs-$(ARCH)-soft-float $(STAGING_DIR)/lib/gcc-lib/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs
endif
endif
+ # These are in /lib, so...
+ cp -a $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib/libgcc_s* $(TARGET_DIR)/lib/
+ $(STRIP) $(TARGET_DIR)/lib/libgcc_s.so.1
gcc: gcc_initial $(LIBFLOAT_TARGET) \
gcc-install $(GCC_TARGETS)