summaryrefslogtreecommitdiff
path: root/openwrt/toolchain/uClibc/patches
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-07 11:57:20 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-07 11:57:20 +0000
commit725611a466f2edf12f809d22339b22223af4afe7 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /openwrt/toolchain/uClibc/patches
parentf4dd5a6d7c4ebea48cd6292744cb9def6037de80 (diff)
move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the developers are ready
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@4944 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/toolchain/uClibc/patches')
-rw-r--r--openwrt/toolchain/uClibc/patches/100-signal_handler_crash_workaround.patch13
-rw-r--r--openwrt/toolchain/uClibc/patches/110-mips_pipe.patch27
-rw-r--r--openwrt/toolchain/uClibc/patches/120-more_standard_math.patch12
-rw-r--r--openwrt/toolchain/uClibc/patches/140-uclibc_do_div_ldso.patch47
-rw-r--r--openwrt/toolchain/uClibc/patches/ipv6_missing_sockopts.patch12
5 files changed, 0 insertions, 111 deletions
diff --git a/openwrt/toolchain/uClibc/patches/100-signal_handler_crash_workaround.patch b/openwrt/toolchain/uClibc/patches/100-signal_handler_crash_workaround.patch
deleted file mode 100644
index 72cdb7212e..0000000000
--- a/openwrt/toolchain/uClibc/patches/100-signal_handler_crash_workaround.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -ur uClibc-0.9.28/libc/sysdeps/linux/mips/sigaction.c uClibc-0.9.28.openwrt/libc/sysdeps/linux/mips/sigaction.c
---- uClibc-0.9.28/libc/sysdeps/linux/mips/sigaction.c 2005-08-18 00:49:44.000000000 +0200
-+++ uClibc-0.9.28.openwrt/libc/sysdeps/linux/mips/sigaction.c 2005-10-20 13:19:05.000000000 +0200
-@@ -49,7 +49,8 @@
- memcpy (&kact.sa_mask, &act->sa_mask, sizeof (kact.sa_mask));
- kact.sa_flags = act->sa_flags;
-
-- kact.sa_flags = act->sa_flags | SA_RESTORER;
-+/* http://bugs.uclibc.org/view.php?id=480
-+ kact.sa_flags = act->sa_flags | SA_RESTORER; */
- #ifdef HAVE_SA_RESTORER
- kact.sa_restorer = act->sa_restorer;
- #endif
diff --git a/openwrt/toolchain/uClibc/patches/110-mips_pipe.patch b/openwrt/toolchain/uClibc/patches/110-mips_pipe.patch
deleted file mode 100644
index 734310f07e..0000000000
--- a/openwrt/toolchain/uClibc/patches/110-mips_pipe.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -ur uClibc-0.9.28/libc/sysdeps/linux/mips/pipe.S uClibc-0.9.28.openwrt/libc/sysdeps/linux/mips/pipe.S
---- uClibc-0.9.28/libc/sysdeps/linux/mips/pipe.S 2005-08-18 00:49:44.000000000 +0200
-+++ uClibc-0.9.28.openwrt/libc/sysdeps/linux/mips/pipe.S 2005-10-20 12:34:52.000000000 +0200
-@@ -10,22 +10,17 @@
- .globl pipe
- .ent pipe, 0
- pipe:
-- addiu sp,sp,-24
-- sw a0,16(sp)
- li v0,__NR_pipe
- syscall
- beqz a3, 1f
-- la t3, errno
-- sw v0, (t3)
-+ sw v0, errno
- li v0, -1
- b 2f
- 1:
-- lw a0, 16(sp)
- sw v0, 0(a0)
- sw v1, 4(a0)
- li v0, 0
- 2:
-- addiu sp,sp,24
- j ra
- .end pipe
- .size pipe,.-pipe
diff --git a/openwrt/toolchain/uClibc/patches/120-more_standard_math.patch b/openwrt/toolchain/uClibc/patches/120-more_standard_math.patch
deleted file mode 100644
index f7d626ac03..0000000000
--- a/openwrt/toolchain/uClibc/patches/120-more_standard_math.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN uClibc.old/libm/Makefile uClibc.dev/libm/Makefile
---- uClibc.old/libm/Makefile 2005-08-18 00:49:41.000000000 +0200
-+++ uClibc.dev/libm/Makefile 2005-10-22 00:56:03.106683500 +0200
-@@ -81,6 +81,8 @@
- w_cosh.c w_exp.c s_fabs.c s_floor.c w_fmod.c s_frexp.c \
- s_ldexp.c w_log.c w_log10.c s_modf.c w_pow.c s_sin.c \
- w_sinh.c w_sqrt.c s_tan.c s_tanh.c
-+# extra stuff required for some apps
-+CSRC+= fpmacros.c nan.c s_rint.c e_hypot.c w_hypot.c
- CSRC+= s_expm1.c s_scalbn.c s_copysign.c e_acos.c e_asin.c e_atan2.c \
- k_cos.c e_cosh.c e_exp.c e_fmod.c e_log.c e_log10.c e_pow.c \
- k_sin.c e_sinh.c e_sqrt.c k_tan.c e_rem_pio2.c k_rem_pio2.c \
diff --git a/openwrt/toolchain/uClibc/patches/140-uclibc_do_div_ldso.patch b/openwrt/toolchain/uClibc/patches/140-uclibc_do_div_ldso.patch
deleted file mode 100644
index b19d55f592..0000000000
--- a/openwrt/toolchain/uClibc/patches/140-uclibc_do_div_ldso.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-diff -ur uClibc-0.9.28/ldso/include/dl-string.h uClibc-0.9.28.openwrt/ldso/include/dl-string.h
---- uClibc-0.9.28/ldso/include/dl-string.h 2005-08-18 00:49:41.000000000 +0200
-+++ uClibc-0.9.28.openwrt/ldso/include/dl-string.h 2006-04-12 11:07:49.000000000 +0200
-@@ -4,6 +4,14 @@
- #include <dl-sysdep.h> // for do_rem
- #include <features.h>
-
-+/* provide some sane defaults */
-+#ifndef do_rem
-+# define do_rem(result, n, base) ((result) = (n) % (base))
-+#endif
-+#ifndef do_div_10
-+# define do_div_10(result, remain) ((result) /= 10)
-+#endif
-+
- static size_t _dl_strlen(const char * str);
- static char *_dl_strcat(char *dst, const char *src);
- static char * _dl_strcpy(char * dst,const char *src);
-@@ -228,7 +236,7 @@
- char temp;
- do_rem(temp, i, 10);
- *--p = '0' + temp;
-- i /= 10;
-+ do_div_10(i, temp);
- } while (i > 0);
- return p;
- }
-@@ -318,7 +326,7 @@
- do { \
- do_rem(v, (X), 10); \
- *--tmp2 = '0' + v; \
-- (X) /= 10; \
-+ do_div_10((X), v); \
- } while ((X) > 0); \
- _dl_write(2, tmp2, tmp1 - tmp2 + sizeof(tmp) - 1); \
- }
-diff -ur uClibc-0.9.28/ldso/ldso/arm/dl-sysdep.h uClibc-0.9.28.openwrt/ldso/ldso/arm/dl-sysdep.h
---- uClibc-0.9.28/ldso/ldso/arm/dl-sysdep.h 2005-08-18 00:49:41.000000000 +0200
-+++ uClibc-0.9.28.openwrt/ldso/ldso/arm/dl-sysdep.h 2006-04-12 11:31:58.000000000 +0200
-@@ -43,6 +43,7 @@
- return m;
- }
- #define do_rem(result, n, base) ((result) = arm_modulus(n, base))
-+#define do_div_10(result, remain) ((result) = (((result) - (remain)) / 2) * -(-1ul / 5ul))
-
- /* Here we define the magic numbers that this dynamic loader should accept */
- #define MAGIC1 EM_ARM
diff --git a/openwrt/toolchain/uClibc/patches/ipv6_missing_sockopts.patch b/openwrt/toolchain/uClibc/patches/ipv6_missing_sockopts.patch
deleted file mode 100644
index 8aed08125f..0000000000
--- a/openwrt/toolchain/uClibc/patches/ipv6_missing_sockopts.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- uClibc-0.9.27-old/libc/sysdeps/linux/common/bits/in.h 2005-01-12 08:59:21.000000000 +0100
-+++ uClibc-0.9.27-new/libc/sysdeps/linux/common/bits/in.h 2005-08-23 02:12:47.000000000 +0200
-@@ -115,6 +115,9 @@
- #define IPV6_MTU_DISCOVER 23
- #define IPV6_MTU 24
- #define IPV6_RECVERR 25
-+#define IPV6_V6ONLY 26
-+#define IPV6_JOIN_ANYCAST 27
-+#define IPV6_LEAVE_ANYCAST 28
-
- #define SCM_SRCRT IPV6_RXSRCRT
-