summaryrefslogtreecommitdiff
path: root/openwrt/target/squashfs-lzma/Makefile
diff options
context:
space:
mode:
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-06 03:34:52 +0000
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-06 03:34:52 +0000
commit9d30652149fd745711342cec7ee8574e973ec241 (patch)
treeaad933069e7dedf29eb70dbfd81e9ca95d9b578f /openwrt/target/squashfs-lzma/Makefile
parent0167360282da38c534a2698b415a8e2bed241d0a (diff)
nbd's makefile/menuconfig rewrite
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@307 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/squashfs-lzma/Makefile')
-rw-r--r--openwrt/target/squashfs-lzma/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/openwrt/target/squashfs-lzma/Makefile b/openwrt/target/squashfs-lzma/Makefile
new file mode 100644
index 0000000000..6c709952e4
--- /dev/null
+++ b/openwrt/target/squashfs-lzma/Makefile
@@ -0,0 +1,16 @@
+include $(TOPDIR)/rules.mk
+include ./squashfslzmaroot.mk
+
+TARGETS:=$(BIN_DIR)/openwrt-generic-squashfs.trx
+
+prepare: $(SQUASHFSLZMA_DIR)/.unpacked
+compile: squashfslzma
+install: $(TARGETS)
+clean: squashfslzmaroot-dirclean
+
+$(BIN_DIR)/openwrt-generic-squashfs.trx:
+ @mkdir -p $(TARGET_DIR)/jffs
+ $(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs-lzma $(TARGET_DIR) $(IMAGE).squashfslzma -noappend -root-owned -le
+ PATH=$(TARGET_PATH) trx -o $@ \
+ $(LINUX_KERNEL) $(IMAGE).squashfslzma
+