summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/linux-2.4/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-10 17:28:44 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-10 17:28:44 +0000
commitcdea47b22effe86885cb0517fe5bdf02d95d1a76 (patch)
treee3416cdc5a44796fe988f7c567553fd2913c9554 /openwrt/target/linux/linux-2.4/Makefile
parent4892ba62ef784a9b300045dad2a803b611196d6f (diff)
ar7: add firmware blob to adsl driver ipkg, update led driver
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1400 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/linux-2.4/Makefile')
-rw-r--r--openwrt/target/linux/linux-2.4/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index 31a3775767..4890816049 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -52,10 +52,10 @@ ifeq ($(BOARD),brcm)
include ./broadcom.mk
endif
+ifeq ($(BOARD),ar7)
+include ./ar7.mk
+endif
-$(eval $(call KMOD_template,SANGAM_ATM,sangam-atm,\
- $(MODULES_DIR)/kernel/drivers/atm/tiatm.o \
-,CONFIG_MIPS_SANGAM_ATM))
$(eval $(call KMOD_template,ATM,atm,\
$(MODULES_DIR)/kernel/net/atm/atm.o \
$(MODULES_DIR)/kernel/net/atm/br2684.o \
@@ -63,9 +63,6 @@ $(eval $(call KMOD_template,ATM,atm,\
$(eval $(call KMOD_template,PPPOATM,pppoatm,\
$(MODULES_DIR)/kernel/net/atm/pppoatm.o \
,CONFIG_PPPOATM))
-$(eval $(call KMOD_template,CPMAC,cpmac,\
- $(MODULES_DIR)/kernel/drivers/net/avalanche_cpmac/avalanche_cpmac.o \
-,CONFIG_MIPS_AVALANCHE_CPMAC))
$(eval $(call KMOD_template,USB_ACM,usb-acm,\
$(MODULES_DIR)/kernel/drivers/usb/acm.o \
,CONFIG_USB_ACM))