summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-17 15:37:37 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-17 15:37:37 +0000
commite20ae4c74e4aa6a8294b1148e3ed263c9fd1f198 (patch)
tree49a0604008f04e542338410aed4a40a546c0b0c8 /openwrt/target/linux/image
parent394273ab20c503db190101e85787b9d0a5e17a73 (diff)
add support for routed RFC2684 encaps. on ATM (patches written by joseangel), close #58
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3003 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/image')
-rw-r--r--openwrt/target/linux/image/ar7/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/openwrt/target/linux/image/ar7/Makefile b/openwrt/target/linux/image/ar7/Makefile
index f5ad6cc660..0b73787854 100644
--- a/openwrt/target/linux/image/ar7/Makefile
+++ b/openwrt/target/linux/image/ar7/Makefile
@@ -27,6 +27,15 @@ $(PKG_BUILD_DIR)/ld.script: src/ld.script.in
sed -e 's/@@OUTPUT_FORMAT@@/$(OUTPUT_FORMAT)/' \
-e 's/@@LOADADDR@@/$(LOADADDR)/' <$< >$@
+$(PKG_BUILD_DIR)/cksum.o: $(PKG_BUILD_DIR)/cksum.c
+ $(HOSTCC) -o $@ $<
+
+$(PKG_BUILD_DIR)/ckmain.o: $(PKG_BUILD_DIR)/ckmain.c
+ $(HOSTCC) -o $@ $<
+
+$(PKG_BUILD_DIR)/tichksum: $(PKG_BUILD_DIR)/ckmain.o $(PKG_BUILD_DIR)/cksum.o
+ $(HOSTCC) -o $@ $<
+
$(PKG_BUILD_DIR)/LzmaDecode.o: src/LzmaDecode.c
$(TARGET_CC) $(CFLAGS) -c -o $@ $<