summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-25 15:40:23 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-25 15:40:23 +0000
commitd13eeb47695992621d9beabe30dcb73a26ca8a31 (patch)
tree34fd65e40faad3e94439d9f9ce6552f274d595b1 /openwrt/target/linux/image
parent99f2cce833a314879ab54ef804f9dba21293baa9 (diff)
add preliminary support for soekris boards
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1564 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/image')
-rw-r--r--openwrt/target/linux/image/Makefile4
-rw-r--r--openwrt/target/linux/image/soekris/Makefile10
2 files changed, 14 insertions, 0 deletions
diff --git a/openwrt/target/linux/image/Makefile b/openwrt/target/linux/image/Makefile
index 73e67a3d1c..6509952fac 100644
--- a/openwrt/target/linux/image/Makefile
+++ b/openwrt/target/linux/image/Makefile
@@ -14,6 +14,10 @@ ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS_LZMA),y)
include ./squashfs.mk
endif
+ifeq ($(BR2_TARGET_ROOTFS_TGZ),y)
+include ./tgz.mk
+endif
+
prepare:
compile:
install:
diff --git a/openwrt/target/linux/image/soekris/Makefile b/openwrt/target/linux/image/soekris/Makefile
new file mode 100644
index 0000000000..bfb2770ef3
--- /dev/null
+++ b/openwrt/target/linux/image/soekris/Makefile
@@ -0,0 +1,10 @@
+include $(TOPDIR)/rules.mk
+
+KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz: $(KDIR)/rootfs.tar.gz
+ cp $^ $@
+
+prepare:
+compile:
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz