summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/jffs2.mk
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-11 21:18:26 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-11 21:18:26 +0000
commita80d25042b8914774c614f8b2ff26e02bcbe0461 (patch)
tree8813ca5ad209754da7f4b71014c7a131ee200196 /openwrt/target/linux/image/jffs2.mk
parent4fba88b87b0e46c76bdc0757e60010affa09f9d0 (diff)
cleanup in target/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1205 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/image/jffs2.mk')
-rw-r--r--openwrt/target/linux/image/jffs2.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/openwrt/target/linux/image/jffs2.mk b/openwrt/target/linux/image/jffs2.mk
new file mode 100644
index 0000000000..02c56817b3
--- /dev/null
+++ b/openwrt/target/linux/image/jffs2.mk
@@ -0,0 +1,30 @@
+JFFS2OPTS := --pad --little-endian --squash
+#JFFS2OPTS += -Xlzo -msize -Xlzari
+
+jffs2-prepare:
+ $(MAKE) -C jffs2 prepare
+
+jffs2-compile:
+ $(MAKE) -C jffs2 compile
+
+jffs2-clean:
+ $(MAKE) -C jffs2 clean
+ rm -f $(KDIR)/root.jffs2*
+
+$(KDIR)/root.jffs2-4MB:
+ @rm -rf $(KDIR)/root/jffs
+ $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x10000 -o $@ -d $(KDIR)/root
+
+$(KDIR)/root.jffs2-8MB:
+ @rm -rf $(KDIR)/root/jffs
+ $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x20000 -o $@ -d $(KDIR)/root
+
+jffs2-install: $(KDIR)/root.jffs2-4MB $(KDIR)/root.jffs2-8MB
+ $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="jffs2-4MB"
+ $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="jffs2-8MB"
+
+prepare: jffs2-prepare
+compile: jffs2-compile
+install: jffs2-install
+clean: jffs2-clean
+