summaryrefslogtreecommitdiff
path: root/openwrt/target/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-02 19:06:50 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-02 19:06:50 +0000
commit0e222f60ff2b22a98094dedba70af5fe75e004c5 (patch)
tree486b047ba364c285eb3a1d526a1bc139b0eb3415 /openwrt/target/Makefile
parenta36312d8f5fc9795bd1065ffb1801d04b50b2d1e (diff)
remove lzma loader config option (make it default) and move it from package/ to target/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@530 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/Makefile')
-rw-r--r--openwrt/target/Makefile14
1 files changed, 2 insertions, 12 deletions
diff --git a/openwrt/target/Makefile b/openwrt/target/Makefile
index c8baab5f7a..6a1bd954a0 100644
--- a/openwrt/target/Makefile
+++ b/openwrt/target/Makefile
@@ -29,20 +29,9 @@ IMAGE_TARGETS += $(BIN_DIR)/openwrt-motorola-$(1).bin
endif
endef
-# Enable loader and prepare kernel
-ifeq ($(strip $(BR2_PACKAGE_LOADER)),y)
-export LINUX_LOADER=$(BUILD_DIR)/lzmaldr
-export LINUX_IMAGE=$(BUILD_DIR)/piggy.lzma
-else
-export LINUX_IMAGE=$(BUILD_DIR)/piggy.gz
-endif
-
-$(BUILD_DIR)/piggy.lzma: $(LINUX_KERNEL)
+$(LINUX_IMAGE): $(LINUX_KERNEL)
cat $^ | $(BUILD_DIR)/lzma/lzma e -si -so -eos > $@ || (rm -f $@ && false)
-$(BUILD_DIR)/piggy.gz: $(LINUX_KERNEL)
- cat $^ | gzip -c9 $^ > $@ || (rm -f $@ && false)
-
TARGET_DIRS:=
TARGET_FS:=
IMAGE_TARGETS:=
@@ -83,6 +72,7 @@ prepare: $(patsubst %,%-prepare,$(TARGET_DIRS))
$(BIN_DIR):
mkdir -p $(BIN_DIR)
+$(INSTALL_TARGET_DIRS): lzma-loader-compile
compile: $(patsubst %,%-compile,$(TARGET_DIRS))
install: utils-install lzma-install $(LINUX_IMAGE) $(patsubst %,%-install,$(TARGET_DIRS)) $(IMAGE_TARGETS)
clean: $(patsubst %,%-clean,$(TARGET_DIRS)) image_clean