summaryrefslogtreecommitdiff
path: root/openwrt/rules.mk
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-28 09:17:29 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-28 09:17:29 +0000
commit50af40000ac37ef921ebd46f6d641959503ee919 (patch)
tree823ff43388135467a5c7a60589acf62d173cedc4 /openwrt/rules.mk
parent16530342e5f63527dc2e0c78dcaef4f4b68ceb48 (diff)
move package/linux into target/linux, use wbx' new kernel code. support building images with more than one kernel, split kernel module parts off of packages that use their own kernel modules (fuse, shfs, openswan). some cleanup in the image building process in target/. image builder is disabled for now, needs some fixing.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1085 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/rules.mk')
-rw-r--r--openwrt/rules.mk5
1 files changed, 0 insertions, 5 deletions
diff --git a/openwrt/rules.mk b/openwrt/rules.mk
index 2cfd208fcc..e69654e0e1 100644
--- a/openwrt/rules.mk
+++ b/openwrt/rules.mk
@@ -69,13 +69,8 @@ TARGET_CC:=$(TARGET_CROSS)gcc
STRIP:=$(STAGING_DIR)/bin/sstrip
PATCH=$(SCRIPT_DIR)/patch-kernel.sh
SED:=$(STAGING_DIR)/bin/sed -i -e
-LINUX_VERSION=2.4.30
LINUX_DIR:=$(BUILD_DIR)/linux
LINUX_HEADERS_DIR:=$(TOOL_BUILD_DIR)/linux
-LINUX_KERNEL:=$(BUILD_DIR)/buildroot-kernel
-LINUX_IMAGE:=$(BUILD_DIR)/buildroot-kernel-image
-MODULES_SUBDIR := lib/modules/$(LINUX_VERSION)
-MODULES_DIR := $(BUILD_DIR)/modules/$(MODULES_SUBDIR)
HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \