summaryrefslogtreecommitdiff
path: root/openwrt/package/ppp
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-07 01:12:51 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-11-07 01:12:51 +0000
commit5dfad9395848f74699752473b825635c30fb5567 (patch)
tree523205d7071063e42f742aeabadd523f78b8504f /openwrt/package/ppp
parentbdd94763c1c3c236e2bd8b2282dad526e08bbb66 (diff)
add hotplug stuff to trunk/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2364 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/ppp')
-rw-r--r--openwrt/package/ppp/Makefile4
-rwxr-xr-xopenwrt/package/ppp/files/etc/ppp/ip-down2
-rwxr-xr-xopenwrt/package/ppp/files/etc/ppp/ip-up2
-rw-r--r--openwrt/package/ppp/files/ifup.pppoa1
-rw-r--r--openwrt/package/ppp/files/ifup.pppoe1
5 files changed, 9 insertions, 1 deletions
diff --git a/openwrt/package/ppp/Makefile b/openwrt/package/ppp/Makefile
index 1b20c4e7cd..eec2bd8462 100644
--- a/openwrt/package/ppp/Makefile
+++ b/openwrt/package/ppp/Makefile
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.3
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_MD5SUM:=848f6c3cafeb6074ffeb293c3af79b7c
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
@@ -82,6 +82,8 @@ $(IPKG_PPP):
ln -sf /tmp/resolv.conf $(IDIR_PPP)/etc/ppp/resolv.conf
install -m0600 ./files/etc/ppp/chap-secrets $(IDIR_PPP)/etc/ppp/
install -m0644 ./files/etc/ppp/options $(IDIR_PPP)/etc/ppp/
+ install -m0755 ./files/etc/ppp/ip-up $(IDIR_PPP)/etc/ppp/
+ install -m0755 ./files/etc/ppp/ip-down $(IDIR_PPP)/etc/ppp/
install -d -m0755 $(IDIR_PPP)/etc/ppp/peers
install -m0644 ./files/etc/ppp/peers/sample $(IDIR_PPP)/etc/ppp/peers/
install -d -m0755 $(IDIR_PPP)/usr/sbin
diff --git a/openwrt/package/ppp/files/etc/ppp/ip-down b/openwrt/package/ppp/files/etc/ppp/ip-down
new file mode 100755
index 0000000000..044759fbf1
--- /dev/null
+++ b/openwrt/package/ppp/files/etc/ppp/ip-down
@@ -0,0 +1,2 @@
+#!/bin/sh
+[ -z "$6" ] || env -i ACTION="ifdown" INTERFACE="$6" PROTO=ppp /sbin/hotplug "iface"
diff --git a/openwrt/package/ppp/files/etc/ppp/ip-up b/openwrt/package/ppp/files/etc/ppp/ip-up
new file mode 100755
index 0000000000..c67a3d03c5
--- /dev/null
+++ b/openwrt/package/ppp/files/etc/ppp/ip-up
@@ -0,0 +1,2 @@
+#!/bin/sh
+[ -z "$6" ] || env -i ACTION="ifup" INTERFACE="$6" PROTO=ppp /sbin/hotplug "iface"
diff --git a/openwrt/package/ppp/files/ifup.pppoa b/openwrt/package/ppp/files/ifup.pppoa
index 51b0fe3344..8928366364 100644
--- a/openwrt/package/ppp/files/ifup.pppoa
+++ b/openwrt/package/ppp/files/ifup.pppoa
@@ -31,6 +31,7 @@ while :; do
usepeerdns \
defaultroute \
linkname $type \
+ ipparam $type \
user "$USERNAME" \
password "$PASSWORD" \
mtu $MTU mru $MTU \
diff --git a/openwrt/package/ppp/files/ifup.pppoe b/openwrt/package/ppp/files/ifup.pppoe
index 9a5d0a3494..da9a441ad9 100644
--- a/openwrt/package/ppp/files/ifup.pppoe
+++ b/openwrt/package/ppp/files/ifup.pppoe
@@ -32,6 +32,7 @@ while :; do
usepeerdns \
defaultroute \
linkname $type \
+ ipparam $type \
user "$USERNAME" \
password "$PASSWORD" \
mtu $MTU mru $MTU \