summaryrefslogtreecommitdiff
path: root/openwrt/package/postgresql/Makefile
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-18 06:34:57 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-18 06:34:57 +0000
commit72d1969f67c376a8513904705f9ac0febe07f991 (patch)
treee6ebdb7b1ef3288be5c8d868847974350beaf317 /openwrt/package/postgresql/Makefile
parent818f981f7736524e5da3bc287471245e8bab8d68 (diff)
Uniformize package Makefile, move ipkg related files to ./ipkg
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@665 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/postgresql/Makefile')
-rw-r--r--openwrt/package/postgresql/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/postgresql/Makefile b/openwrt/package/postgresql/Makefile
index 3582a89169..12fbde5001 100644
--- a/openwrt/package/postgresql/Makefile
+++ b/openwrt/package/postgresql/Makefile
@@ -87,9 +87,9 @@ $(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
install
$(IPKG_LIBPQ): $(STAGING_DIR)/usr/lib/libpq.so
- $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_LIBPQ) libpq.control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_LIBPQ) ./ipkg/libpq.control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
mkdir -p $(IDIR_LIBPQ)/usr/lib
- cp -fp $(STAGING_DIR)/usr/lib/libpq.so.* $(IDIR_LIBPQ)/usr/lib/
+ cp -fpR $(STAGING_DIR)/usr/lib/libpq.so.* $(IDIR_LIBPQ)/usr/lib/
$(STRIP) $(IDIR_LIBPQ)/usr/lib/*.so*
mkdir -p $(PACKAGE_DIR)
$(IPKG_BUILD) $(IDIR_LIBPQ) $(PACKAGE_DIR)