summaryrefslogtreecommitdiff
path: root/openwrt/package/openvpn/Makefile
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-08 07:49:20 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-08 07:49:20 +0000
commit7c012cb13763e00aed89c9335da3d5d0ecef16d7 (patch)
treed92bd0ca1cff5ca4a329e555c9166566e48af402 /openwrt/package/openvpn/Makefile
parentf70ad84812afa0a2b10f6dc82e126cb805b268d3 (diff)
update to 2.0.2, make http proxy an option, default on, adds 5kb
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1878 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/openvpn/Makefile')
-rw-r--r--openwrt/package/openvpn/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/openwrt/package/openvpn/Makefile b/openwrt/package/openvpn/Makefile
index f6a0b5a931..bf0ada2c43 100644
--- a/openwrt/package/openvpn/Makefile
+++ b/openwrt/package/openvpn/Makefile
@@ -3,9 +3,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=openvpn
-PKG_VERSION:=2.0.1
-PKG_RELEASE:=2
-PKG_MD5SUM:=fad7a08c0d68371c2c0e6428bcb98fa5
+PKG_VERSION:=2.0.2
+PKG_RELEASE:=1
+PKG_MD5SUM:=862f8788f080f669b1ae00a74ef68001
PKG_SOURCE_URL:=http://openvpn.net/release @SF/openvpn
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -28,6 +28,9 @@ endif
ifneq ($(BR2_PACKAGE_OPENVPN_SERVER),y)
DISABLE_SERVER:=--disable-server
endif
+ifneq ($(BR2_PACKAGE_OPENVPN_HTTP),y)
+DISABLE_HTTP:=--disable-http
+endif
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
@@ -62,9 +65,9 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
--disable-plugins \
--disable-management \
--disable-socks \
- --disable-http \
$(DISABLE_LZO) \
$(DISABLE_SERVER) \
+ $(DISABLE_HTTP) \
);
touch $(PKG_BUILD_DIR)/.configured