summaryrefslogtreecommitdiff
path: root/openwrt/package/openntpd/Makefile
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-23 20:19:42 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-23 20:19:42 +0000
commit7bf482253faf075f55556b69a3908f1c859d8322 (patch)
tree5e7a96353995aaa1301a9b4548cab2ef6b52043d /openwrt/package/openntpd/Makefile
parentb1b9d8388faa032c2ab4f8b2249967ad64cc7617 (diff)
fixup openntpd package. ntpd now starts as user ntp and
CONTROL/postinst can be executed on host and target system. idea from nbd to use IPKG_ROOTDIR git-svn-id: svn://svn.openwrt.org/openwrt/trunk@435 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/openntpd/Makefile')
-rw-r--r--openwrt/package/openntpd/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/openwrt/package/openntpd/Makefile b/openwrt/package/openntpd/Makefile
index 8094e5ef7a..3f6f950377 100644
--- a/openwrt/package/openntpd/Makefile
+++ b/openwrt/package/openntpd/Makefile
@@ -42,6 +42,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
--mandir=/usr/man \
--infodir=/usr/info \
--with-builtin-arc4random \
+ --with-privsep-user=ntp \
);
touch $(PKG_BUILD_DIR)/.configured
@@ -49,11 +50,10 @@ $(PKG_BUILD_DIR)/ntpd: $(PKG_BUILD_DIR)/.configured
$(MAKE) -C $(PKG_BUILD_DIR)
$(PKG_IPK): $(PKG_BUILD_DIR)/ntpd
+ mkdir -p $(PKG_IPK_DIR)/usr/sbin
+ cp -a ./ipkg/* $(PKG_IPK_DIR)/
$(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
- mkdir -p $(PKG_IPK_DIR){/usr/sbin,/etc/init.d}
cp $(PKG_BUILD_DIR)/ntpd $(PKG_IPK_DIR)/usr/sbin/
- cp ./files/ntpd.conf $(PKG_IPK_DIR)/etc/
- cp ./files/S49ntpd $(PKG_IPK_DIR)/etc/init.d/
$(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
mkdir -p $(PACKAGE_DIR)
$(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)