summaryrefslogtreecommitdiff
path: root/openwrt/package/ncurses/Makefile
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-20 01:26:06 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-20 01:26:06 +0000
commitcff46ac78e59b61a0f11d4be5701a9fa7eb98c10 (patch)
treece27659e1f6b00cd647947d2067f0cebbd0473ff /openwrt/package/ncurses/Makefile
parent225e7dd7ee3d282ebaa8f7ae41b75db0160a2b4d (diff)
add mirrors and md5sum
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@396 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/ncurses/Makefile')
-rw-r--r--openwrt/package/ncurses/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/openwrt/package/ncurses/Makefile b/openwrt/package/ncurses/Makefile
index 633fc9f765..9b64016274 100644
--- a/openwrt/package/ncurses/Makefile
+++ b/openwrt/package/ncurses/Makefile
@@ -3,8 +3,14 @@ include $(TOPDIR)/rules.mk
PKG_NAME := ncurses
PKG_VERSION := 5.2
PKG_RELEASE := 5
-
-PKG_SOURCE_SITE := ftp://ftp.gnu.org/pub/gnu/ncurses/
+PKG_MD5SUM := 464d6a49010cf2a6eb9ce59a264d4d47
+PKG_SOURCE_SITE := ftp://ftp.gnu.org/pub/gnu/$(PKG_NAME) \
+ ftp://gatekeeper.dec.com/pub/GNU/$(PKG_NAME) \
+ ftp://ftp.uu.net/archive/systems/gnu/$(PKG_NAME) \
+ ftp://ftp.eu.uu.net/pub/gnu/$(PKG_NAME) \
+ ftp://ftp.funet.fi/pub/gnu/prep/$(PKG_NAME) \
+ ftp://ftp.leo.org/pub/comp/os/unix/gnu/$(PKG_NAME) \
+ ftp://ftp.digex.net/pub/gnu/$(PKG_NAME)
PKG_SOURCE_FILE := $(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_CAT := zcat
PKG_SOURCE_DIR := $(PKG_NAME)-$(PKG_VERSION)
@@ -14,7 +20,7 @@ PKG_IPK := $(PACKAGE_DIR)/lib$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).i
$(DL_DIR)/$(PKG_SOURCE_FILE):
mkdir -p $(DL_DIR)
- $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE_FILE) x $(PKG_SOURCE_SITE)
+ $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE_FILE) $(PKG_MD5SUM) $(PKG_SOURCE_SITE)
$(PKG_BUILD_DIR)/ipkg/rules: $(DL_DIR)/$(PKG_SOURCE_FILE)
mkdir -p $(TOOL_BUILD_DIR)