summaryrefslogtreecommitdiff
path: root/openwrt/package/mtd/Makefile
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-04 00:03:48 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-04 00:03:48 +0000
commit06768f3ee0842f5e076c55777ba85e593b14e632 (patch)
treea308a7ea62294791ade7d73bb172fd273458fbb2 /openwrt/package/mtd/Makefile
parent8821f2c334d201c53b86bbd181c295bafead7e8b (diff)
link to specific header, just to be safe
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1841 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/mtd/Makefile')
-rw-r--r--openwrt/package/mtd/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/openwrt/package/mtd/Makefile b/openwrt/package/mtd/Makefile
index bfbb301e4c..b2090a6e49 100644
--- a/openwrt/package/mtd/Makefile
+++ b/openwrt/package/mtd/Makefile
@@ -7,6 +7,10 @@ PKG_RELEASE := 1
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+ifeq ($(LINUX_VERSION),2.4.30)
+VER=-DLINUX_24
+endif
+
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,MTD,$(PKG_NAME),$(PKG_RELEASE),$(ARCH)))
@@ -16,7 +20,7 @@ $(PKG_BUILD_DIR)/.prepared:
touch $@
$(PKG_BUILD_DIR)/.built:
- $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
+ $(TARGET_CC) -I$(LINUX_DIR)/include $(VER) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
touch $@
$(IPKG_MTD):