summaryrefslogtreecommitdiff
path: root/openwrt/package/chillispot/Makefile
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-19 21:14:18 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-05-19 21:14:18 +0000
commita30fc45109b8f41d789036bdd9cc1ed9125ed2f8 (patch)
treeb8351969b1dadbaabafe43482b81fc9ec7aaabaa /openwrt/package/chillispot/Makefile
parent29dc4733187277b90e3671e5443eb620b75740fd (diff)
Tweak package build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@968 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/chillispot/Makefile')
-rw-r--r--openwrt/package/chillispot/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/openwrt/package/chillispot/Makefile b/openwrt/package/chillispot/Makefile
index cacaee2553..81937aab79 100644
--- a/openwrt/package/chillispot/Makefile
+++ b/openwrt/package/chillispot/Makefile
@@ -50,14 +50,14 @@ $(PKG_BUILD_DIR)/.configured:
);
touch $@
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS)
+$(PKG_BUILD_DIR)/.built:
+ rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
DESTDIR="$(PKG_INSTALL_DIR)" \
- install
- touch $(PKG_BUILD_DIR)/.built
+ all install
+ touch $@
$(IPKG_CHILLISPOT):
install -m0755 -d $(IDIR_CHILLISPOT)/etc/init.d