summaryrefslogtreecommitdiff
path: root/openwrt/package/bluez-libs/Makefile
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-10 16:06:24 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-10 16:06:24 +0000
commit14428f9a610d763126cbcf9b841dd2140aa7d8eb (patch)
tree8d5d1cb1834673f54bf26163e53efd692657d167 /openwrt/package/bluez-libs/Makefile
parent62ad947afed2dc3df42d295eec5c0afb0fbca513 (diff)
Fix building when host and target systems are same arch
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1597 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/bluez-libs/Makefile')
-rw-r--r--openwrt/package/bluez-libs/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/openwrt/package/bluez-libs/Makefile b/openwrt/package/bluez-libs/Makefile
index 6a65590842..17ac5a1164 100644
--- a/openwrt/package/bluez-libs/Makefile
+++ b/openwrt/package/bluez-libs/Makefile
@@ -27,7 +27,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+ LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
sys_lib_dlsearch_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
sys_lib_search_path_spec="$(STAGING_DIR)/lib $(STAGING_DIR)/usr/lib" \
./configure \
@@ -81,6 +81,7 @@ $(STAGING_DIR)/usr/lib/libbluetooth.so: $(PKG_BUILD_DIR)/.built
install-dev: $(STAGING_DIR)/usr/lib/libbluetooth.so
uninstall-dev:
+ rm -rf $(STAGING_DIR)/usr/include/bluetooth
rm -rf $(STAGING_DIR)/usr/lib/libbluetooth.{a,so*}
compile: install-dev