summaryrefslogtreecommitdiff
path: root/openwrt/package/Makefile
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-19 23:06:12 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-09-19 23:06:12 +0000
commitf05ca573eafe7c7f2d937d25a581bde22bc9ba88 (patch)
tree7898312d10da75e90c33b3f9bcbee43d2e2ef835 /openwrt/package/Makefile
parent2ad7eff7cde70d12f93d80636d54b75176f8e25e (diff)
enable all packages when DEVELOPER=1,
add curl and gmp extensions, fix gd extension build git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1948 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/Makefile')
-rw-r--r--openwrt/package/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index ef6a712730..99447a8d3d 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -293,9 +293,15 @@ openvpn-compile: lzo-compile
endif
php4-compile: openssl-compile zlib-compile
+ifneq ($(BR2_PACKAGE_PHP4_MOD_CURL),)
+php4-compile: curl-compile
+endif
ifneq ($(BR2_PACKAGE_PHP4_MOD_GD),)
php4-compile: libgd-compile libpng-compile
endif
+ifneq ($(BR2_PACKAGE_PHP4_MOD_GMP),)
+php4-compile: gmp-compile
+endif
ifneq ($(BR2_PACKAGE_PHP4_MOD_LDAP),)
php4-compile: openldap-compile
endif